2.0.8 crashes Logic Pro X 10.5.1 validation

Hi, got this while trying to run Logic Pro X 10.5.1. Seems like Scaler 2 2.0.8 crashes the plugin validation. Is this alright?

Reset and Rescan selection with Scaler 2 highlighted and you should be good to go. Seems 10.5.1 Logic update is causing a wide range of issues across plugs because It is rescanning the lot.