2.4.0 VST3 Crashes Cubase 10.0.30 on Mac [Fixed Version number]

This is new. I worked with Scaler in Cubase just fine. When I tried to reopen the session Cubase would crash loading the plugins. The crash report said Scaler 2 was the cause. I believe it was the VST3 version since Cubase seems to default to that if available. This was repeatable.
I was able to bypass the plugins and open the session and removed Scaler and the crash stopped. I then tried Scaler VST version and that seems to work.
I do have a crash log if you’d like to see that.
Mac OS High Sierra. iMac iMac (27-inch, Late 2013) 3.2 GHz Intel Core i5 24 GB 1600 MHz DDR3
Scaler 2.4.0

2.4.0 is latest version of Scaler offered to me at PlugBou. Is 2.4.1 available?

We had this problem last time, where PluginBoutique seems to do a rolling release between the full Scaler 2 version and the Upgrade from Scaler 1. I bought the upgrade, and don’t see 2.4.1. yet either…


My mistake - I actually am using 2.4.0. I don’t know where I got the .1 - maybe I saw it here as coming and it stuck. Correcting now.

Aha, I see. I figured you were in on the early Beta :wink:

I have the same issue on a 16" MBP “Big Sur” and Cubase 11 Pro such that I have had to “quarantine” Scaler 2.4 for the time being. Hopefully the next update will allow me to use it again.

I didn’t have trouble before I went to Cubase 10.0.30. I may roll back and see if that fixes it.