2.4 Installer Errors In Windows 10

It should be saving the files to the current structure which is:

C:\Users\Public\Public Documents\Plugin Boutique\Scaler2

Yes. But it is the antivirus. I have Avast and it showed me several virus suspicious file messages.
I disabled Avast until the next reboot and everything was fine

I have no AV installed on my Studio PC. I only connect it to The Net when I need to update it. It’s trying to install to directories that do not exist.

My suggestion is to PULL 2.4 from the PB site until this is fixed otherwise customer systems may be FUBAR’d. :slight_smile:

Hope you solve it soon. This update is very good for us. I only told you about the antivirus because in my case it gave a lot of suspicious file messages, analyzing, etc.

@jjfagot What Operating System are you using?

Install went smoothly here in Win 10 this morning.


Weird. I even tried installing it as Administrator and STILL it kicks out that error.

why don’t just skipping that file?
maybe is not so useful… :grinning:
FLAC is an audio file I think, so maybe that installing without e.g. extra instruments can do the job

And you can check the Windows error list feature to look for further details

Another possible issue is this one

Hi @LightWingStudios

Can you please send this screenshot from your computer please:

But that structure is not mandatory
For example, I just created the Scaler/Sounds folder in my external HD and all FLACs (that are the Scaler’s instruments) are gone there smoothly

Windows 10. I deactivated the antivirus and everything was fine

I just did a Super Mess by purpose

Installed Scaler 2.4 with sounds in my external HD, writing the folder wrongly: Scaler instead of Scaler2

Moved FLAC files (never installed before this release) from my external HD to C:\Users\Public\Public Documents\Plugin Boutique\Scaler2\Sounds

Moved the whole Public Documents\Plugin Boutique\Scaler2 folder from my internal HD to the external HD

Launched Ableton and Scaler works
:saxophone: :mega: :guitar: :boom:

But I have Windows 8.1
Windows 10 sucks

1 Like


I created a “Documents” folder and copied the PB directory, with subdirectories over to it.

Here is the requested Screenshot. Also, please explain the error that the Unstall DOES NOT exist in the directory when it DOES. See Screenshot also attached.

@Frederic I get the same error when the program tries to install the “Manual” PDF file. Then get the same messages to all the sound files being installed. ALL the files exist in the appropriate directories/subdirectories the Install programs wants to use. I currently have version 2.3.1 installed and working perfectly.

@ClaudioPorcellana Checked the file permission…full control access.

Perhaps, someone is interested in what I already mentioned on another occasion:
Due to the amount of hard drive Scaler used, I tried FreeMove.

It is a free application that allows you to move any directory to any location (internal or external drives). You simply have to run it as an administrator, select what you want to move and where you want to move it.
On this occasion, when I installed the update, all the files went directly there without problems

@LightWingStudios Thanks for your information.
I managed to reproduce this error.

Click on start then type “virus”
Click on “Virus & threat protection”
Scroll down to “Controlled folder access”
Click on “Manage controlled folder access”
Switch it off
Lunch install again and you should be fine.


@Frederic THAT DID IT! Looks like an obscure “Ransom Ware” protection schema in Win 10. Never had this issue before which is crazy…probably the result of a Windows Update recently which MS doesn’t tell you they are doing. Thank you so much for all your help Frederic! :slight_smile: