2.6 freezing/crashing Logic and other issues - Mac Studio m1

Hi Guys, I am new to this forum but I have been the Scaler for a few years now.
I am reaching out on here because I am having quite a few frustrating problems with version 2.6.
I get a lot of spinning wheel of doom when using the newest 2.6 version, but also other unusual behaviours.

I recently upgraded from my 2008 Mac Pro to Mac Studio M1 (Monterey 12.4) and I am using Logic 10.7.4.

Yesterday I was sketching a simple track with 4 instances Scaler, all running the same chord progressions but each one with a slightly different performance mode.
2 of them are driving 2 instances of M-Tron Pro by GForce, and other 2 are driving Logic’s own samplers.
The session was running pretty much fine yesterday, I saved it to continue today, but today when I reopened, I noticed that the presets I used in both M-Tron’s are reset to default state.
In addition, the Logic samplers programs I used yesterday also changed.

I did a bit of investigating, re-installed Scaler, as well as M-Tron Pro, and after restarting the computer, the yesterday’s session opened just fine.
However, as soon as I tried to open Scaler’s window I got a spinning wheel and Logic was frozen unresponsive. I force closed it and reopened it again, but just as previously M-Tron sounds were not gone.
I tried something different this time and loaded some random presets to one M-Tron but as soon as I pressed play in Logic, M-Tron goes back to default (empty state).
I tried to replicate the presets changing issue with other instrument plugins I have installed on my machine, also with the use of performance on Scaler, but I run into series of other issues, even just when opening Scaler’s window Logic crashes.
Besides Scaler frequently crashing Logic, I also I get a lot of hanging notes which I am unable to cut neither with a midi panic button in Scaler or Logic.

I am happy to share crash reports and screen recordings to help rectifying the issues.

Welcome to the forum @Recbutton
Thanks for reporting that is strange behaviour. There has been some odd reports of M1 Mac Studio users which our DEVS are looking into, in the meantime can you try opening Logic under Rosetta and see if the issues your are having persist?

Hi Davide
Thanks for your reply with suggestions.
I experimented a bit and I actually experience more crashing when running Logic under Rosetta and using Scaler.
Initially things run smooth, but as I add complexity and more Scaler instances the crashes appear and then it is impossible to re-open the projects.
In native mode, I can at least re-open the saved project and disable the Scaler(s) or disable the instrument and render midi performance in Scaler.
It would also appear that Scaler does’t like some plugin instruments more than the others.
I experience quite a lot of problems with M-Tron and Strings Machine by GForce Software, which I use frequently.
There might be actually a cross problem or interference on both sides in that instance, however I don’t think I ever had a problem with GForce instruments crashing Logic when used without Scaler.

Thanks @Recbutton That’s highly curious behaviour and something is wrong here. I very much doubt there is a conflict between software. My first questions is have you downloaded that correct GForce Installers? If you head over the their website they have some confusion on whether you need to be running intel M1 installers or M1 Native installers, go to their support page and click FAQ and your instrument.
Irrespective I would ask that you open a clean empty project (not an existing or template) and load only multiple scalers. Is there a problem there?

Hi @davide
I have had to play around with it for a while to try to understand what is happening but there are very strange things happening.
First of all, yes I have the newest versions of both GForce plugins, I double checked and even re-installed them.

Below are my observations:

  • Several times I opened a fresh session and loaded plugins one by one. For example, first M-Tron, then I loaded preset on it, and then I would open Scaler. As soon as Scaler loads, the presets on M-Tron go to default (blanc). I can then load new preset on M-Tron and play it through Scaler and selected chords, but if I try to record my performance, as soon as I press play, or record in Logic, the preset on M-Tron disappears again. On several occasions I managed to go beyond that problem and actually record and play the performance but say I would want to tweak parameters on M-Tron, Logic instantly quits.
    (When running Logic under Roseta, either I get a spinning wheel after loading more than one instance of Scaler with GForce plugins or Logic instantly quits).

  • As suggested, I loaded several Scalers to see what happens.
    First I tried the exercise with a few Scaler instances as Instruments, using internal sounds. I tried synchronising them, loading different sounds on each and every one and using different phrases in performance modes. No problems, it would appear that everything works fine.

  • Then I tried loading several Scalers as MIDI FX, this time for different plugin instruments (I specifically avoided using GForce and used Audio Damage Quanta, NI Kontakt, Logic’s sampler and Retro Synth).
    First of all, when even a single Scaler loads it creates a hanging note. That is right away after loading and it is impossible to kill it with midi panic button. The only way to silence it, is to load some chords and play them, but as soon as the play is pressed in Logic, same thing happens again.
    When trying to build a more complex performance with several Scalers, it usually results in a havoc. Instruments play random notes or play out of tune, lots of hanging notes etc.
    It is honestly impossible to explain it without demonstrating it.

  • I also decided to test Scaler with a couple of my hardware poly synths to see what happens.
    I opened a new session in Logic, loaded a couple of external instruments as plugins and initiated Micromonsta1 and Micromonsta2 by Audiothingies (I usually run all my external gear into Logic anyway and use with plugins etc.).
    As soon as I opened Scalers for both synths one by one, the presets change. On MM1 to P002 and on MM2 to P001 , irrespective of what preset number was previously selected. I repeated that several times and the change is always the same, on MM1 to P002 and on MM2 to P001.
    Again, I can load different preset but as soon as I press play in Logic, the presets change (just like with GForce plugins).
    Another thing is, when Scaler is loaded (in a blank state) and play is pressed in Logic, it creates hanging notes.
    What I also noticed is that on MM1 screen there is an indicator for incoming midi messages. When Scaler loads, that indicator blinks as if some message was received. The same happens every time when I press space bar for play in Logic with scaler just loaded.
    It would appear that Scaler is sending some midi messages when loading and when transport is played.

I’m also having similar issues with an M1 Mac Mini running the latest version of Logic, OSX and Scaler (as a Midi FX). The presets/settings for my instrument patches were mysteriously changing back to default or random patches, either during work on a session or when I re-opened a project. This was happening with both native Logic instruments and 3rd party instruments. I lost hours recreating patches and trying to figure out what was going on. I eventually narrowed it down to the Scaler Midi FX instance on each of the effected tracks. I actually had Scaler disabled on those tracks but it still caused the weird patch changing behaviour. Removing Scaler from the tracks solved this problem, I haven’t had any issues over the last few days after removing Scaler from the tracks.