3 Scaler instances and nothing else freeze Ableton Live

I don’t remember if it happened in the past because I use rarely more than one or two instances

Anyway, I just run Ableton Live 11 (last update), I drop 3 Scalers, and Ableton freezes
No flags from RAM or CPU loads, an all seems otherwise fine, but I must click on Task Usage then kill Ableton

The @jamieh workaround worked :grinning:

Just tried it with 4 x scaler playing, and it seems to work fine … here’s the machine usage
4 x scaler

1 Like

Thanks @yorkeman, I fixed the issue with the @jamieh tip linked above

Nevertheless, disactivating OpenGL is not painless: the Scaler GUI behaves strangely, so I hope the issue will be fixed by devs

No issues here either. Just did a tutorial with 5 instances on Wintel (10) with the latest Ableton 11.1

1 Like

I see, but in my case at least, I can use more than 2 only disactivating OpenGL that is not painless

What do you mean exactly? You should just need to do I once in ScalerSettings. You’re not disabling it system wide.

Yes, but after doing that the Scaler GUI behaves in a different way from the norm
difficult to say what happens, because it could need a video and I am not good at videos
I can survive to it anyway :grinning: