A possible bug

yesterday night I created a nice series of chords in a blues style, added drums and bass, then added the guitar to test the solo binded to chords

I was ultimately able to have my solo synched with muted chords, with only the flaw mentioned here

after some test I realized it was late so I saved the Scaler state Scaler-State_2020-10-13_001238.xml (7.3 KB) then saved the project under Ableton an gone to bed

now I reopened the project but I am no more able to play the solo
there is no more binding with chords ARGH
I pushed all possible buttons but the green keys play notes that don’t match chords, no more

what can be happened?
:scream:

Hi @ClaudioPorcellana

thanks for reporting and attaching the state file, we will have a look.

Cheers,
Ed

1 Like

thanks
I add some insight

I tested a basic preset, bossanova 4, and found that green keys work perfectly when you record nothing: simply tapping chord keys with my left hand and fiddling green keys with my right hand works and there is no conflict between chord sound and solo sound as I mentioned here

the problems raise when I record something, even a few chords of bossanova 4, then I mute chords and try to do the solo: sometimes it works, sometimes not, and in the latter case I can only close the Ableton project and restart the whole

I also noticed that when a line (A or C) is binded, and Scaler is in synchro with the DAW, when I push the space bar to start the song, the chords top bars (red lines in my screen-shot) flashes one after the other untill the end of the cycle is reached, then those flashes stop

I noticed that this cycle of flashes is the sign that green keys can be used

I also noticed that sometimes the DAW is not in synchro, even if I set it as default
I don’t know why the default option is overridden, but I have a suspect: maybe one of the keys of the chord/pattern conflicts with a shortcut, as e.g the key that mute/unmute the output?

about the Scaler case I uploaded, the chords top bars don’t flash anymore
unfortunately I don’t remember if yesterday night they flashed but it is plausible they did

that’s all for now, I have to nap

BTW, I just noticed now that a similar bug was fixed in the latest release

Fix notes being cut-off on chord change when using Keys-Lock - Scale White Keys

Hi @ClaudioPorcellana,

reloading the state you provided end up with a session like this one:

The sound is turned OFF and the Keys-Lock is active but in order to be able to play the keyboard keys that have a green border you have to first play a chord (using one of the grey keys that represent the MIDI bind or by clicking onto a chord from the UI).
Playing a chord will feed notes to the keys-lock that then will propagate onto the green bordered keys of the keyboard. After that you will be able to either click on those active keys or use your MIDI keyboard to trigger them.

Active keys look like this:


or:
image
depending on which keys-lock mode you are using.

Just to be sure, is the possible bug you are describing is the fact that when reloading your session those green bordered keys are “not yet” active?
Knowing that you saved your session with those green keys active, you expected to have them active when reloading your session?

Or are you talking about another issue?

Cheers,
Paul

1 Like

Hi Paul, thanks for your help

the sound is OFF because I always use Scaler to drive another plugin, usually Ezkeys
:grinning:

in order to be able to play the keyboard keys that have a green border you have to first play a chord

I know, and this is not showed by the xml: actually the Ableton Scaler lane had a MIDI that was recordered before switching to solos; so Scaler synched with the DAW should re-play the same accompaniment and I can play solos together it, if I don’t understood it badly

and yes, those keys were active when I muted chords and when I reopened the project

now, I don’t have the problem using chords un-muted and pushing them with my left hand while I use green-keys with my right hand
or the opposite, i.e. tickling bass green keys on the extreme left (left to the dark grey keys) and using green-keys with my right hand

ouch!

I see that you refer to another support request of mine, and I replied thinking to the other, not to the current one :grinning:
sorry

anyway I have 2 issues both linked to muted/un-muted chords and green keys

the first one is that I can use for solos a few green keys, not the dozen apparently available

the second issue is that when a chord changes, regardless of they are muted (and I uses Scaler with a pre-recorded MIDI) or un-muted and I play live, the sound produced by the green key stops

this seems similar to the other old bug, only with green keys in the place of white keys:

Fix notes being cut-off on chord change when using Keys-Lock - Scale White Keys

this is not a big problem if I only use some more notes to embellish the expression, phrase etc, but if I want do e.g. a guitar solo with long notes, possibly going after the current chord, the effect is totally ruined by the abrupt stop

I hope I explained well enough the 2 issues that I have

well, about this precise issue (to be added to the others 2 above) I noticed that sometimes, if I un-mute then mute again the chords, the Synch to DAW option that is usually set ON by default is de-selected: this may explain while reopening the old project I was unable to play the solo

I don’t know if I’ll have the time to do more accurate tests tomorrow
I’ll do them likely on Sunday and let you know if I can reproduce this 3rd issue

Ok, great, keep me posted, please.

To sum-up:

  1. first issue: you can’t use all green keys
  2. second issue: green keys are cut-off when the chord change
  3. third issue: mute/unmute/mute is disabling the Daw sync

About the first issue, when using KEYS-LOCK modes “Chord Notes” and “Chord Extensions,” the available notes on the green keys will depend on the pressed chord.

As you can see here, you will have only 5 different pitches, and when repeated the pitch associated with key labelled “1” will be played at the different octaves.
Was this the issue you where experiencing? Part of the green keys where repeated.

About the second issue: we are working on a fix.

About the third issue: this should not happen, unmuting/muting again is not affecting the daw sync in our tests. Please, if you have any more details about this one, we would be glad to have them to replicate on our side and hopefully find a fix, thanks.

Cheers,
Paul

Hi Paul

after a refreshing and relaxing hiking in the mountain, with some deers and the nuthatch observed, I can do some test now :grinning:

a very simple one: 2 chords
Scaler-State_2020-10-17_221115.xml (5.5 KB)

with 2 chords un-muted and binded I obtain a different note from almost all the 14 green keys; I say almost because some notes are similar or identical, but most are different

with 2 chords muted and binded in the same way, then looped as per xml I obtain the same note from all the first 4 green keys, then another note from the following 5 green keys, and a 3rd note from 4 the last 4 green keys: so only 3 different notes in total…

about that I am almost sure I de-synced the DAW then I went to sleep, and the next day I forgot to have de-selected it
:grinning:

now I understand why some notes “seem” similar: they are the same note on another octave

nevertheless, I see 7 pitches here

Hi Claudio,

The number of unique pitches you see “re-mapped” to those green keys depend on the last chord you played before using those green keys.

Is it more clear as to how the keys-lock adapt to the last played chord?

Do you have other related questions?

Cheers.
Paul

P.S.: Hiking is and will always be an excellent way to refresh! If you can’t go hiking make sure to use the “Abstract - Nature” Theme in Scaler until we add a hiking feature that’s the best we can offer yet :stuck_out_tongue:

1 Like

The number of unique pitches you see “re-mapped” to those green keys depend on the last chord you played before using those green keys.

yes, I understand that, and I understand there are limits in whose notes that can match with a chord

nevertheless using one chord only, the behaviour changes if I use the chord with sound un-muted or muted: how do you explain this?
:wink:

here is a possible Scaler background…

[quote=“luapmartin, post:13, topic:5215”]

2 Likes