Ableton crash when reopening Scaler plug in screen (and another crash issue)

Hello all, I will provide other pertinent info as needed… but I will start here. Also, I will say that my issue could be Ableton related, as I have had this specific issue happen with another VST. So, this post is more looking for a suggestion/possible answer/seeing if this is happening to anyone else. I will also post a similar thing in the Ableton forums.

Also, I have searched the forums with no luck in finding an answer - or even a similar instance as mine.

The issue I have comes when I close the Scaler 2 plug in window in Ableton. I have no issues at all with USING Scaler, and am - in fact - enjoying it… but, after I close the Scaler window, if I were to try and reopen the window (using the wrench icon on the plugin box in Ableton), it crashes Ableton.

I HAVE had this issue once before when I made a big old ugly patch in Vital, but I took that to be an Ableton/resources issue, as I have since gone back, modified power settings and other latency issues in the Ableton DAW. But, this Scaler issue happens without fail AND I installed Scaler after fixing this prior issue.

Today, I tried to circumvent this by creating the chords, dragging them to a midi track, deleting the initial instance of Scaler (after closing the window) and then trying to add a new instance of Scaler in a blank MIDI track. This ALSO caused Ableton to crash. I am at a loss, and am now reaching out the forums to get advice, find a fix… see if I am alone in this issue. A “fix” would be to not close the Scaler window, but that’s not a true fix. I SHOULD be able to close it and reopen it without this happening.

Some specs, and I will provide more if/when needed.

Windows 7 - up to date on all service packs (yeah, I know… I am waiting to get a newer computer to finally upgrade to WIN10)
Current version of Ableton 10
NEW and current version of Scaler 2
32Gb of ram
1TB ssd
MOBO is a bit older - thus why I can’t do WIN10 - and without digging, I am unsure of how to give full specs
Older I7 processor
Windows power settings are on High Performance

If you need other info, please let me know and I will provide it.

Again, Scaler works… but this one very specific issue/crash - happens without fail. I am going to do another test about instances of Scaler in Ableton. I’ll let you know what I find.

Anyway… anyone else have this happen… even if not with Scaler - maybe you have some Ableton specific insight?
Is this an Ableton with Scaler issue… or an issue specific to one or the other?
Anyone able to help?

Small update.

I went through and brought in Massive, and Vital, closed both windows and reopened them. I brought in Scaler, closed it, deleted the track (all tracks, actually) and then brought in Vital, and it crashed (again, after introducing Scaler in). I tried various things without Scaler… no problem, but the second I introduce Scaler in to the session and then close it, it does this. I am leaning more on a Scaler issue at this point.

I will do other tests - like saving it before closing Scaler and seeing if I can open that project and load other things. I’ll do that tonight after work.

So, hopefully, someone can help. As it stands now, after I bring in Scaler and close it/delete the track it’s on, it crashes Ableton. In fact, it crashes so hard that I have to reboot in order to even reopen Ableton again. That’s a huge bummer.

Hi @Bentelli

thanks for reporting with detailed info. There is an update coming next week which will improve the stability of Scaler.

We will check for this specific issue on our side.


1 Like

Ed, thank you for your comment. I hope it does fix my issue. I’m really enjoying what I can see I’ll get from scaler, and while I could come up with work arounds, it’d be nice to not interrupt workflow.

Another update, this is definitely an issue with Scaler as I don’t have any other VST issues (beyond pushing processor with big patches).

Again, Scaler works, but I’m unable to close the window and reopen.

This also means, I cannot save a project that uses Scaler, as it defaults to being closed when I reopen a project.

Current workaround is to record the midi and save it, close that project, make a new project, and bring the saved midi files in.

I want to reiterate, I love the program, but I hate this bug. If I have to use my workaround, then so be it.

Still, if you guys come across any reason for this and are able to fix it, that would be awesome. I’d love to have Scaler at the ready, instead of going to multiple projects to save midi files.

I see that a new build of Scaler is out. Am I able to download it and see if this fixes my issue?

The new version is 2.2.0 and is available free of charge from your plugin boutique account.

Thank you. I will check it out tonight after work.

I just want to say… THE UPDATE FIXED IT!!! Thank you!!!

Spoke too soon. I’ll investigate a bit more here.

But, saving a session with Scaler in - close session and reopen - opening up scaler - bam - crash.

Until that point… I could open multiple scalers - route to other instruments and all that. I could close the window and reopen in Ableton.

Just accessing after saving/closing/reopen. Still, work flow is improving over here.