Any progress on Scaler 2.5 crashing Ableton Live?

Hi! I love scaler, but it crashes Ableton Live 11 on my 2018 macbook pro running mojave 10.14.6 so often its become extremely difficult to be creative with. I am constantly losing chord progressions in the middle of working, which is obviously as about frustrating as frustration can be. Its the only plugin I use that causes crashes in Ableton. Does anyone have any reports on fixes?

Have you tried turning off OpenGL? That worked for me in Cubase.

Hi Jamieh,
Much thanks for the reply - I have now disabled opengl as advised - fingers crossed :+1:
Thanks!
Tom

Unfortunately, this did not solve the crashing in Ableton Live 11. Open GL is disabled, still lots of random crashes. Would love to get word from Scaler - any fix for this?

Also, more bad news - When ableton crashes, whatever changes have last been Saved to the session are not recalled on relaunch. unfortunately Scaler is becoming unusable. Please pipe in anyone -

Update - the crashes are becoming regular and more frequent. Scaler is the only plugin crashing ableton like this. Any thoughts, Scaler?

What Scaler are you using VST, AU or VST3? What are you doing when the crash occurs? Any commonalities? If you have Scaler in a session alone does it crash? Are you using the latest Ableton 11.0.12? Anything else you can tell us about your setup that might help. Can you pst a Live session that has crashed?

Hi Jamieh, I’m using Ableton 10.0.12 and Scaler VST. macbook pro 2018 with touchbar running Mojave 10.14.6
Even if I use scaler in this small empty project with only 1 ableton synth, it crashes randomly when i try to edit chords in a pattern. Also, when it crashes, even if I’ve saved the pattern, it reopens as whatever version of the pattern existed before the run of ableton in which scaler crashed.
Here is a link to the ableton project:

Thanks Jamieh, Let me know your thoughts

You mean 11.0.12 right? That’s what it says it was created with. There doesn’t seem to be a problems so far. What do you do when you edit a chord? Change notes or… ? There is a missing plugin called VSX. What did that do. It was on the master out.

Apologies, that was a typo. Yes, I am in 11.0.12
VSX is an audio plugin. Scaler crashes whether or not that plugin is in the session