Are user chord sets broken in Scaler 2? Saved Sets not displaying as the manual suggests

Hi guys. The first few times I saved a chord set I had assumed you changed something in how Scaler 2 handles user chord sets, but looking at the manual the saved chord set is not behaving as shown in the manual.

Additionally, saving a set creates 2 files, and appends a string of text that was not part of the name I typed. One file always contains the text pattern, the other file always contains session + the date.

I’m pretty sure I understand what each file is, the problem is that it doesn’t show up as a single file in the browser. And, after renaming some sets last night chord set files that had previously shown up stopped showing up.

The last behavior appears to be some kind of bug. I unfortunately I can’t figure out the steps to reproduce it consistently, all I know is one of my folders now shows less sets than I have in there, and they were displaying fine until I had moved one of them into a sub-folder, renamed it, and refreshed the list. Suddenly that folder only showed 3 saved sets when It should have display 7 or 8. (In other words the menu had shows 6 or 7 files that had been renamed without issue. After renaming the file I did last night suddenly only 3 would appear.)

Trying to move things around and rename things won’t solve the issue. Even dragging the xml into Scaler and saving again does not fully fix the issue. Then it would display 4 only, the remaining sets refusing to display. I’ve attached screenshots that show what I’m referring to, an explanation of the screen shots below.

  • You can see I save a set called “Chords Test”.
  • Based on the behavior of Scaler 1, and according to the Scaler 2 manual: The user menu should show 1 chord set called Chords Test.
  • Instead, as you can see the user menu shows 2 files, one with session 1 appended, another with sessions-2020-06-17 appended.

Some of this appears to be unexpected behavior. That said, this is all quite a bit confusing compared to Scaler 1…

All of these should be displaying, most were until renaming one yesterday.

Now as you can see only 3 display after renaming.

1 Like

I have noticed that if you want to import you first need to clear, otherwise your import will append to whatever is already there.

This appears to be part of the problem that you may be experiencing.

Thanks. That said it’s still a mystery as to why patches that were displaying suddenly decide to not to show up. You can see 10 patches in the folder, but only 3 display. (And as I said, initially they displayed fine. All I did was rename one of them, which I already had done to each previous one and they displayed, and boom 7 of them are suddenly not visible…)

I’d also appreciate if someone could explain why I see two patches but the manual suggests I should only see one. (In the ‘Chord Sets’ section.)

Seems like there are some bugs to me, if not it would be useful if someone could expand on the differences not explained in the manual.

Hi @zedsdeadbaby

We have found an issue when re-exporting chordsets with the same filename which will be fixed in the next update.

We are still having a look at your other issue with the chordsets disappearing.

Thanks for reporting,

Thanks a bunch Ed. Interestingly that’s part of what may have caused the issue since I believe I did re-export the same file after some editing… The other thing I did in that session was drag drop audio, in case it’s related in any way… If files would be useful for investigating the bug just let me know… Best.

Hey @Ed1 . I’ve done some tests and I’m seeing this behavior across the board. Even if I start with a completely fresh instance of Scaler 2, capture some chords, and export as a completely new file with a different name I always wind up with 2 files when saving the chord set: One with “session 1” appended, another with the date appended, always saved to a discrete folder. The manual shows that I should see a single file like Scaler 1.

This is not only confusing, it’s a lot less straight forward than how Scaler 1 handled user chord sets. If I’m not understanding something it’d be appreciated for some clarity that’s not covered in the manual. If this is by design I hope you’ll consider some kind of alternative, 2 of everything and folders inside of folders is a messy way to handle presets.

I’ve linked video of this happening in real time. I used a fresh instance of Scaler 2 in a freshly opened project. The only current solution for me is to capture chords in Scaler 1, then copy the xml files to Scaler 2’s folder. Not the most elegant way to work… See video…

Hi @zedsdeadbaby

there’s a few different things here:

  • Scaler 1 chord sets are fully compatible with Scaler 2. We had to keep a part of the logic so you can create something in Scaler 1 and import in Scaler 2. Or create a chordset in Scaler 2 and share it with a user of Scaler 1
  • Scaler 2 allows you to export individual patterns but also complete sessions which is a new behaviour

When you press save, we create a folder using the name you want, we then:

  • Save each of your patterns to file (they only contain chords, NO timing and NO articulation information)
    • Those can be recalled like any other as Chordsets in Section A in Scaler 1 or 2
  • Save one file representing your whole Scaler 2 session, with:
    • All your patterns with articulations, duration/repeat values per chord…
    • UI theme/size used in your session…
    • Selected scales, global voicing override…

The current solution was the most versatile one and was working out of the box for new users and for people coming from Scaler 1 with already a lot of content.

Thanks for the feedback and the video, we understand it can be confusing and are currently working on improving this area.

Why not have Scaler save separate folders for patterns & sessions? Also am I supposed to be able to rename the pattern file? As I mentioned in the video this worked the 1st few times then suddenly broke and now most files in one folder refuse to display… Renaming, removing, and refreshing various files hasn’t restored the non-visible files from displaying.
Thanks again…

Because that would have been confusing in its own way as well…

I think your chordsets not showing might just be a formatting issue in the file due to a bug we have now fixed.

Would you mind sending me some of those files that do not display in Scaler?


Thanks for clarifying @Ed1… The XML files have been uploaded. Best.

Hey @Ed1, I discovered something while trying to troubleshoot this just now… I followed these exact same steps in the order below with a new chord set. I was able to make the preset disappear from view, then reappear several times by renaming/undoing parts of renaming and refreshing the user menu.

  • If I move the “session” xml file to a folder of my choice and refresh everything displays fine.
  • If I remove the appended -Session-date (e.g. 2020-06-27) then refresh, the preset does not display.
  • If I undo the renaming in Finder (so it once again displays -Session-date), then refresh, it displays again.
  • If I remove the date only, (i.e. deleting 2020-06-27, but leaving -Session in the name) then refresh, the preset displays fine.
  • If I complete the renaming by removing -Session then refresh it disappears, if I undo deleting -session then refresh, it appears again.

Apparently Scaler 2 currently doesn’t like having -Session removed from the name. Or at least my OS/machine.

I can provide video of this happening in real time if that would be helpful.

Aha!! If I manually type or paste -Session back to the file names of the XML files that have refused to display they appear again. I have attempted this on 2 files so far and now my user folder displays both of them again…

Perhaps this is by design? Needless to say it would be nice to be able to remove “-Session” and the date from the file name, and allow the user to move the pattern to their own folder if the user desires. As I mentioned things start to get cluttered and quite difficult to digest scrolling through a list of sets that all have the same word/date scheme appended to them…

I know you don’t want to risk confusing users whom this works for… I’d be content if Scaler allowed the user to manually move Session and pattern files to separate folders and rename them if they so choose to… Any chance this could be available as an easter egg?

Yes, we have been working on this, it will be part of the 2.0.9 update.

Ability to rename and move files around :slight_smile:

Thanks for your patience,

Excellent! Really appreciate you guys understanding. :metal:

Hello I can’t save my user chord set. Have I done something wrong?

From a new instance of Scaler 2 on an instrument track (Pro Tools).
Select “scales” (Section A), “C Major” (Section B), Pick few chords from there and place them on section C (eg C maj, Fmaj, G maj, C maj).
Press “SAVE” on section C, “NAME YOUR CHORD SET” box comes up.
type a new name and press “OK”, nothing happen. This saving “user chord set” box still there, the only way to close it, is to click “CANCEL” so the new user chord set is not saved and its not appeared in the “USER” chord set tab.

Can someone help please?


Welcome LJ

I’ve tried to replicate your issue but no joy.

Is this the same Name Your Chord Set box you get:

  • If not, are you on the most current version? 2.4
  • If so, have you tried both bottom options (blue dots)?

Can you export chords from the User Chords button in section A?

Hello TMacD

Thank you for your reply. This is the same box I am referring to. I believe I am also on the latest version of Scaler 2.

I have tried to use both options, only one option, use replace existing, but they all came up the same. I have a screen capture video on a new Pro Tools session, however, I am not be able to upload to this forum.

Please help.


You’ll need to host it to an upload service. Google Drive, Dropbox, or the Vimeo free account.

I viewed it but no luck in noticing anything odd.

However, I did have luck in reproducing your issue when I pointed my Chords Location in preferences to a read only directory. This might be your issue.

Check your prefs here.

My default location is: C:\Users\Public\Documents\Plugin Boutique\Scaler2\Sets

Good luck!