Audio detection not working

Can’t get audio detection working.
When I drag file to Scaler 2 - nothing happens.
Video -

1 Like

Hi @lipatovroman,

the Apple loops (.caf) and mp3 audio format are not currently supported.

Current supported formats are

  • wav
  • aif
  • flac

Hope this helps,

So, Scaller should display message “This file type not supported”.
Why we have to waste time to find reason of problem?

Yes, the visual feedback on wrong format drop could be improved.

In the meanwhile this information and other interesting details about how to use Scaler 2 and what to expect from it can be found in the manual:

If you have trouble finding answers in the manual, please come back here.

Hope this helps,

Ok, why when I press on source button it displays only midi?
Where is audio?
Screenshot -

There’s a host of resources on this forum, there is also a manual and lots of tutorial videos and in depth videos like this one ( ). Please refer to those resources as it makes it easier for us to address and filter any issues that we need to prioritise.
Your understanding is appreciated.


I’m using Scaler 2, 2.0.7 with Cubase Pro 10.5. If I drag midi in to Scaler it works fine, audio doesn’t, I just get the little ‘not allowed’ sign. The Audio files are Wav.

edited to add, I have tried all the settings of the blue dot slider but it makes no difference.

More editing.

Right, I have found a video you put up David about different methods of audio detection so thanks for that. The only one I could make work was putting Scaler Audio on an audio track as an insert, Scaler does then detect the incoming audio. However, it is wildly innacurate!
I have recorded a completely clean 4 bar guitar part that is just a G major then an A7 repeated. Scaler picks up each chord change but throws them up as every imaginable chord under the sun! Every key and flavour of chord in a completely random fashion, only very occasionally hitting one chord correctly.

This isn’t intended as criticism David, I love Scaler and I think you’ve done an amazing job on it but I’m clearly doing something wrong here and I’d like to get to the bottom of it. I write on the guitar and this would be a very handy way of getting chord progressions in.

I tried altering the input levels on both the tracks and Scaler and tried adding distortion and gain in case it just wasn’t driving enough into Scaler.

I don’t know if you have Cubase as a test platform but if you have I’d dearly like you to chuck me a few sentences explaining your methods! Cheers.

1 Like

Any chance you could link us to that audio file and some text describing the chords you are playing and we can test on our end and go from there?

Sorry David haven’t forgotten. Just got my business up and running again and my workload is ridiculous! Will try to get on this at the weekend.

Did you ever solve your audio problem in scaler I am having same problem

1 Like

Welcome @Jules9906
Please make sure you are using an audio file with a sample rate up to 88.2kHz. Anything beyond is not supported

1 Like

Thanks will give that a try today

Hi, I too am having issues with this. Plus points for the plugin but it really is not detecting chords in simple pieces even.

I am using solo instruments, piano. and it is repeatedly mostly throwing back incorrect suggestions/interpretations.

Would appreciate the help.

PS to repeat the pianos are all well recorded sample pack solo’d instruments and should be detectable.

Hey @skank

there are definitely cases where the audio detection is not helpful, but those solo instruments should work.

Would you mind sharing a couple of samples so we can run tests on our end?

1 Like

Hi @Ed1

Thanks for getting back - yes I would be surprised at complex pieces but I’m feeding it pretty simple stuff. I’m probably doing something wrong.

Thanks in advance,

PS DM’d the file to you

FWIW, my experimenting with audio detection shows that it has a number of variables which will can impact your results. For example, the level you set will can impact the resulting detection as can the instrument you have selected w/in Scaler. (each instrument has processing applied which seems to slightly impact detection) . Also, importing an audio file directly might result in a different detection than using the monitor mode. Take for example the following detection(s) from the same audio clip:

  1. Input Level set to 4 of 7 (0 to 6) A
  2. Input Level set to 2 of 7 B
  3. Input Level set to 2 but instrument set to OFF C
  4. Import of audio file via drag and drop (did not record the Instrument setting) D

Another element that might impact your detection is hot audio inputs. If you have an active mic, it will be added to the input signal and might impact detection.

I tend to think of audio detection as more art than science and more muse than instructor. :slight_smile:


This is incredibly helpful, whilst also being concerning.


“This is incredibly helpful, whilst also being concerning.”
I understand your concern, but this must to some extent be a fact of life ? Triads played using some wide-spectrum synth patch will surely not get interpreted as well as a piano ?
Whilst there are some specialist apps to do tis well, Scaler is not materially worse than my other general audio tools, and I’m sure it will evolve.

@yorkeman Thanks for your input.

I think some misunderstanding, as I never mentioned ‘wide-spectrum synths’. I did state I am using solo’d instruments, principally piano.

I wasn’t sure what to do with this, I think my comment wasn’t a casual critique of Scalar but an expression of some concern and whilst we also agree bugs are often a ‘fact of life’, forums like this are here in part to help mitigate some of that fact.

Sorry, this was meant as a generic comment on audio detection in Scaler, rather than being directed to your specific instance - I should have been clearer, apologies.

1 Like