AutoPlay... keeps crashing!

When you’re trying out the many options via the Performance Panel, it’s great to be able to Right Click on the Play Button, in Section A and just have it continually play while you change the settings. However, I’m finding more often than not, AutoPlay stops… there is a bug in the system! The only way I seem to be able to reactivate this, although only till it crashes again, is by using the Clear State option and starting again!

I’m on Mac using the latest OS and Logic Pro X.

Hi @Alfie

Sorry to hear you’re having some troubles with the Autoplay feature.
We don’t have any problems using the autoplay feature on our various macs running logic in our studio and this is the first time we have heard of this issue, it behaves rather solid from our testing.
Could you ensure that you are running the latest update of Scaler 2 (2.8.1) if you are not already.

Does the Autoplay stop randomly or when you select a new pattern? Does it stop at the end of the songsets or anywhere in the middle?

Could you also confirm that this happens in a fresh blank Logic project and with a cleared Scaler to start with.

Anything of significance might help us to recreate what you are experiencing.

Hi I’ve tried this several times. Starting with a fresh start and only one track. I started with C Major, using Common Progression number 1. Sometimes it doesn’t play at all. Although I get Auto Play On… nothing!

When I have got this to work, by closing Logic and starting again, when I’ve tried various options such as Performance, Songs, Scales and Artists etc, it just crashes randomly. I’ve gone from using Logic in M1 mode to Rosetta mode as I don’t think Scaler is up to working with the M1 chipset, but still have the same results.

Have you turned off OpenGL?