Bug in G natural minor?

Using Scaler Control 2.6.0 au as MIDI Fx inside Logic 10.7.4.
Locking keys to G natural minor. But it forces you to play Ab, not A.

This is weird. Under Windows, it appears to be as expected

Is this a MacOS thing ? Mac users, have a go …

Yes. As Yorkeman says, it’s weird.
Are you sure you clicked in g minor?
What appears in your image is g phrygian

Yes, I’m sure. I coud be wrong, but the screenshot is crystal, says “G Minor Scale”. And I promise I did not forge the image :slight_smile:

I believe you, of course.
I use Windows and it may be a problem with Mac. Hopefully someone can check in Logic. I tested it on Live and Reaper, and as you can see, it works fine.
Anyway, take the test. Click on G minor. It should appear blue, and in your image it is not blue

Now it works! :grinning:
Thank you very much. Yes, with an extra click to make it blue, now it works as it should. Seems a little confusing but I guess that it is a feature, not a bug.
Thanks again for you both! :smiley:

1 Like