Can you help me understand how Scaler's tempo relates to my DAW?

I am trying a Scaler demo, and have become curious to learn how or if Scaler 2 syncs with the tempo of my hosting DAW.

For example; I wrote a melody in my DAW’s piano roll. It was a simple eight bar form with a quantized eight note melody line. I used Scaler to detect the MIDI and suggest the song key.

Then I used Scaler to map out a chord progression. When I dragged the chord progression onto a track in the DAW the timing of the clip was half the expected length. I intended the notes of the chord to be whole note block chords, but they were half note length so I had to snap each chord form to the correct beat and stretch the note length to align the chords with the melody’s MIDI clip.

I figured out that if I changed the Settings > Playback > Chord Duration from 4 beats to 8 beats that the next time I dragged the clip it synchronized with the DAWs tempo. The thing is my DAW was set to 4/4 time so it would seem that 4 beats would have been the correct choice in the settings dialog to export or drag whole notes at the specified tempo.

It’s not a big deal, but if I can learn to understand more about the relationship between the timing of the host DAW and the Plug-in it would be appreciated.

Windows - Reaper 6.667 - Scaler 2 Audio VST3i

Scaler is always syncing to daw in terms of what is going on when you are playing scaler or when you are in DAW sync mode, when you are dragging and dropping there is no sync going on as that would be difficult. I sometimes just record the trigger notes in and then hit play and MIDI CAPTURE in scaler and then drag to DAW. Simple process and gives me exactly what I want. Otherwise you can do as you did and adjust chord duration. Hope that helps.

Hi, Thank you for sharing your comments.

With respect, the fact that the dragged clip is exactly half the expected length when the number of beats is matched in Scaler and the DAW, and then the dragged clip is exactly the correct length when the number of beats in Scaler is twice that in the DAW makes me think that the explanation for why this is happening must have a more specific explanation than that would be difficult.

I am open to the possibility that I am doing something wrong or have a check box with the wrong option selected, etc.

Or maybe it is just a quirk of Scaler. If so, it seems like there must be a good reason why it happens, and I would really like to understand what is going on.

Thank you!

If you are using a 4/4 time signature and your global chord duration is 4 beats then you should be good, otherwise something is not right on your end (time signature, sample rate etc). In my example I have 4/4, chord duration set to 4 beats, drag four chords, each chord is 4 beats (1 bar)

1 Like

Works the same for me in Ableton Live and Cubase. 4/4 time signature Scaler set to 4 Beats = 1 measure. Mac OS. Never had any issues and I use the edit section to give me chords of different lengths if needed for a piece.

1 Like

Hi to both,
Thank you for the follow up comments, the screen shots, and the confirmation that everything seems to work in sync.
I don’t know what I was doing wrong. I just went to make some screenshots that illustrated the circumstance I was describing, and now everything works just like it does for you.
The only thing I should make note of, though I suspect the issue was caused by my misunderstanding something rather than a software issue, is that I updated Reaper from 6.66 to 6.67 last night.

Thanks very much. I think I am done with the demo phase and looking forward to purchasing a license and getting Scaler set up on my studio DAW tomorrow morning.

Thank you!!!

Are you dragging chords out of Section C? If so there is a duration setting for each chord pad there. So while you have it set to 4 beats in your global chord duration, in section C it could be set to 1/2 the duration, so 1/2 of 4 beats or a half note, etc…

Thanks for the tip. I went and found the setting you pointed out. It will be helpful to know it is there and it is possible to make a change.

This morning, I saw the issue while demoing the ability to detect a MIDI melody and construct a chord progression, but I figured out that Scaler was set to Settings > Playback > Chord Duration > 2 beats, which appears to be the default.

I was able to quickly switch to “4 beats” and everything was fine.

Lots to learn.

Thank you!

1 Like