Clicking on Arpeggio Feature Keeps Causing my Logic Pro X to Crash!

Every time I click on the arpeggio feature while Scaler 2 is loaded as a MIDI FX within Logic, it immediately causes my session to crash! The arpeggio performance feature is completely unusable! Please Help!!

Hi @kapkid

Thanks for reporting your issue, we are aware of it and working on a fix.

The next update is planned for next week and should fix this issue alongside a few others.

In the meantime, try to lower your samplerate, and/or disable the audio detection from the top section of Scaler. This should make it more stable.

Hi Ed, Same issue here using Bidule Standalone, and Element Host Standalone.

Any update on a fix or a a beta to try ?

Cheers
Matt

Hi @CompleteCycle

an update will be available next week. Thank you for your patience.

1 Like

Still instant crash here.

Any host, log from live 9.7 pointing to

Crashed Thread: 3 AudioCalc

Hey @CompleteCycle

which audio interface do you use? And what samplerate/block-size are you running at?

Also, have you tried to run Scaler without OpenGL rendering? You can disable it from the “ScalerSettings” application.

Arp still hard crash.

Turned off Open GL

Buffer 512 samplerate 44.1

Motu Ultralite mk3

OSX High Sierra

Not better for me with the update (2.3) … still “arpeggio” crash …Pro Tools, Logic Audio or Kontrol… same issue…

Hi @PMAudio

sorry to hear you are still having the issue as well. We are looking into it.