Could not Install Scaler 2 in Logic Pro

Here are some quick tips to how to install Scaler 2 in a Logic Pro DAW in 5 simple steps:

  1. Once you have installed the file package “Scaler 2” in the preferred drive, you have to locate and copy the file “ScalerControl2.component”;
  2. Paste that file in the Macintosh HD->Library->Sound->Plug-ins folder;
  3. Open Logic Pro X and start a new project with any midi instrument (for instance electric piano);
  4. Click on the arrows button in the Midi effect slot in the Track inspector and select AU Units->Plugins Boutique->ScalerControl2;
  5. Once the Scaler interface appears push the Close button. A new window will automatically open to register the product license. In order to validate it, open the license file in the specific field and then type your mail address and confirm.
    Enjoy this fantastic program as a plugin.

HI @genedrummer and welcome to our community. I am not sure why this is posted here? Setting up is very easy and this post seems superfluous?

Hi Davide, and thank you for the answer. The problem is only the first step for mac users-dummies like me. I didn’t find any information in the installation instructions (2.0.7) about this step. Infact, if you try to open directly Logic pro X Daw after the installation of the plugin and go to the midi effects pop up menu, nothing appears. I spent more than one hour to search some instruction or tip to overcome this deadlock. Neither Apple gives any information about the insertion of the custom plugin ScalerControl2 file in the plug in folder of the application Logic Pro X to activate the Third parties plug in midi effects menu. The result is that you can’t activate the licence and can’t enjoy quickly the program. This is my personal experience. I hope it could help someone.

It worked for me without any manual steps. I just used the installer afaicr

It sounds like you encountered a common quirk since OS High Sierra in that at times you need to reboot your Mac for the system to recognise a newly installed VST/AU. I may change the title of your post as it may confuse our users.

Thank you Davide. You are right. I tried to reinstall Scaler 2 in the main drive (Macintosh HD) and all went well.

Quick Tipp:
if you are familiar with the terminal you can also type:

killall -9 AudioComponentRegistrar

without restarting.

1 Like

Trying to activate Scaler 2 in GarageBand (High Sierra) , but the “Register a licence file” link in the About window does not allow me point to the licence file. It is unresponsive in GarageBand. I have experienced other “sandbox” issues before. Curious about the Terminal command above - will this allow me to authorize my Scaler2?

The terminal command that I mentioned above has nothing to do with the licensing of Scaler and only replaces restarting the Mac if the plugin was not recognized immediately after installation. Apparently you have a problem with the scaler and Garageband and with this combination I have no experience. I advise you to make a new topic with this particular problem so that you get more attention and answers to your question.

1 Like