Crashing on M1 Mac

I love Scaler 2 but it crashes my LogicPro usually within 5 minutes of using it. I can’t find a particulr series of events that crash th esysytem, it seems random but consistent. Any helpout there. How do I upgrade scaler 2 (2.2.0) to 2.6?

Hi, and welcome.

I’m a PC person, but if you search the board for ‘logic pro crash’ there are many entries, and you may find one (and probably a solution) that fits your situation.

Search button is top right corner.

Welcome to the forum, Christoph and the world of Scaler.
Scaler and M1 do not quite get along on all systems. This is a known issue, has been worked on but is still not perfect. One thing you can try is running Scaler under rosetta as it seems to help some people. Also disable Open GL for Scaler as that is an issue on some systems. A quick search will show that.
To update just login to your plug-in boutique account and under the Scaler download will show the various versions. If you don’t see it right away just click on the version number to see the list.

Screen Shot 2022-07-22 at 7.18.11 PM

Thank you for the reply. I will be investigating and trying a few tings know I know its a known issue.

Cool…I will try that…just did the tech and will try it out and let you know!