Cubase 10.5 Drag/Drop Audio

I bought Scaler 2 this morning and I’m trying to use it in Cubase 10.5 Pro. I’m able to drag/drop full audio files from the Media Browser into Scaler, However, if I try to drag and drop audio from the timeline into Scaler, it just shows a circle with a line through it and doesn’t allow it. Is there a trick to making that work? or is that a known issue that’s being worked on by chance?

Alright, well nevermind. I see that Cubase 10.5 Pro isn’t supported for Scaler 2, and Trying to use it in Cubase 10.5 Pro causes some seriously weird issues with making the mouse jump when you’re trying to edit Midi and other things. So I guess the above problem is the least of my worries there.

Hi @dfmsguitar and welcome,

do you have the latest update 2.1.2 installed?
This update has improved the overall stability of the application:

Regarding your first issue, Cubase does not support the drag and drop of audio file onto Scaler, but you can go in the “Detect” screen and select “Open Audio File” from the source dropdown:

Screen Shot 2020-10-05 at 12.34.55 pm

1 Like

Thanks Ed, I didn’t realize there was a newer version since the download page defaulted to Version 2.1.1 - I just uninstalled 2.1.1 and installed 2.1.2, and so far everything seems to be fine. I was able to duplicate the issue every time I tried to use 2.1.1, so it seems like that did resolve it.

Thanks for the quick reply. Scaler 2 is a pretty awesome plugin overall. I’m just getting started with it, but I really like what it has to offer, so I’m glad to hear I’ll be able to use it in Cubase.