DAW crashes when Scaler present


I use Scaler v 2.0.9 with Studio One 5.

Since a couple of weeks now (since upgrading Scaler maybe? I cant remember whether Scaler was updated) the following actions cause the DAW to crash when Scaler is present as a track:

  1. attempt to remove Scaler from the session
  2. attempt to close the session (but not Exit the DAW)

I typically use Scaler within a session and then I need to remove it as an instrument when I bounce all tracks to audio and remove the instruments from the tracks.

Can anyone help me?


1 Like

2.0.9? 2.2 is coming out today…

You may want to wait for it.

Have you seen the video on 2.2?

I have not, i’ll take a look, thanks.

1 Like

Hi @DPCampbell, yes, please, come back to us after your tests.

Hello there, I watched the video and cant wait to get started. But when I install it, to the same directory as the previous version, I go to the DAW:

  1. if i create a fresh song, and drag Scaler to a track, it is still version 2.0.9, with obviously the same problem I had in my original message.
  2. if i go to an existing song and select the Scaler instrument on the existing track, this is also 2.0.9, with obviously the same problem as above.

I thought, ok should I uninstall and do a fresh install of Scaler and use the new version, but I am worried that should I do this then those songs which have existing Scaler instrument tracks will crash or somehow be corrupted and I will lose them. I have this thought by following the rationale that, ok removing the scaler crashes the DAW so it might be possible that a song opening and then not finding this instrument will cause a problem.
I love the look of the new features but I am obviously reticent to use an instrument which I cannot then remove down the road when I dont need it as an instrument track anymore. I have it on some important tracks.

Can anyone help?


also tried dragging another instrument onto the scaler track and choosing to replace scaler with the new instrument, but this also crashed the DAW.

Can anyone help here?

Hi @DPCampbell, sorry for the delay,

it seems you are still running 2.0.9 which was causing those crashes, they should be fixed in 2.2.
Did you manage to install it and replace 2.0.9?

The projects you created will be compatible with Scaler 2.2, if you want to be extra-safe, you can open your projects and export the state of Scaler to a file from the Settings menu.

On top of that, in case anything goes wrong you can always reinstall 2.0.9 and reopen your projects.


Hi Ed, thanks for your message. The problem is that although I installed 2.2 to the same plugins folder to replace 2.0.9 when I go to my DAW and open up Scaler it is still 2.0.9.
This is whether I begin a new song and drag Scaler to a fresh track - 2.0.9
When I open an existing song and look at the Scaler instrument there it is still 2.0.9

Could it be that 2.0.9 is being replaced by 2.2?

Thanks again

If what opens up in your DAW is 2.0.9 it means the file have not been replaced properly.

It could also be that you have 2 copies of the VSTs on your disk, the installer copied over one location but the DAW is seeing the other one.

You can go in your VST folder location and delete the previous Scaler files by hand before running the installer again.

This should make sure you are running the latest.


ok thanks Ill try this, but I’ll have to first make sure I have all the stems etc exported as losing this song would be a killer.

Well, I was having trouble summoning up the courage to remove the old scaler plugin before installing 2.2 in case my songs wouldnt open.
but it solved itself. i open my daw this morning and it said it couldnt register the (old) scaler plugin.
The songs still worked, I could delete the old scaler files and install 2.2 and i’m back in business.
so the old life lesson is correct. if you have a problem,ignore it and it will solve itself eventually.

To Whom It May Concern:

I set up a session with about 12 instrument tracks in Pro Tools 11 and when I inserted Scaler 2 onto one of them the whole session crashed!?! Can anyone expalin why this has happened?


Scaler 2 is once again crashing my Pro Tools 11 DAW!?!?
What is happening here? I have a lot of work to do and this is killing my creative spirit…
Can anyone please help me?

Hi @violin_guy_2021

there are a couple of things you can try that can make Scaler more stable on your setup:

  • lower your samplerate to 44.1 or 48KHz
  • disable the audio detection (click on “audio” in the top section)
  • disable OpenGL rendering from the ScalerSettings app

The next update is planned for the end of the month, it will improve stability and fix lots of crashes.
I hope this will help in the meantime.