DAW Sync issue with Studio One 5.3 and Scaler 2.4.0 VST3

Problem: Recorded MIDI out of sync w/ timeline and metronome

Repro:

  1. Start new Studio One song
  2. Insert Scaler 2 as an instrument track
  3. Open Scaler 2 UI - set up simple C maj scale and enable DAW sync
  4. Add a 2nd Instrument track in Studio One - set input for “Scaler 2” output, and ARM for record
  5. Press record

Scaler 2 now plays the C maj chord on bar boundaries and the MIDI output is recorded in 2nd track.

Problem: Stop and zoom in on the recorded MIDI. The notes don’t fall on the bar markers but are late.

With some of the Perform patterns and with the metronome enabled, its clearly audible that Scaler 2 is not playing its pattern in sync with the DAW click.

Thanks - very excited about Scaler 2 if I can figure out some of these gremlins.

1 Like

Hi @mgarrett33 and welcome to the forum.

It is something we have been noticing as well and are about to release an update that addresses the issue.

It has been a big piece of work but Scaler 2.4.1 will be a lot more precise along with other improvements, bug fixes and new content.
The update should be available next week, we are doing the final stage of testing now.

Cheers,
Ed

5 Likes

Welcome, @mgarrett33 mgarrett33…I’m also a Studio 1 user, and I’ve seen this from time to time, but not always.

I’ve mostly done the reverse - create a pattern in Scaler and then move to an S1 instrument…but I have seen what you see a few times.

You may be a more advanced S1 user than me…but feel free to PM me if you ever want to trade notes. Still on a learning curve with Scaler and S1.

Excellent news. Thank you for the quick response and I look forward to 2.4.1.

Mike

Same. I don’t know if I’m “advanced”, but I am interested in using the capabilities of Scaler for demo creation using other VSTs as instruments. So I love that Scaler can drive MIDI out that can then be routed to other instruments. The only issue currently is the timing is off.

Mike

I’ve never experienced that myself. When I record the MIDI or Drag and Drop, it’s always right on the beat. On a Mac. Usually in Ableton Live or Cubase.

What if you Drag and Drop the MIDI from Scaler? Is it still out of sync?

I’m on Mac OS High Sierra. I just did a test in Studio One 5 both record and Drag and Drop with performance on and it was right on the beat even with quantize turned off.
Are you on Windows?

Sorry I haven’t had a chance to try that. I’m much more interested in being able to naturally record the MIDI out in real-time.

Yes I should have said that. Windows 10.

I have yet to find a way to turn the quantize off in Scaler 2. I only see the two “Play Quantize” options “Chord Duration” and “Next Beat”. Both result in the same misaligned output. Is there a way to turn it completely off?

When you say naturally record, do you mean you’re playing the parts?