Default Windows Audio Device driver can cause MIDI note hanging in Performance Mode (but there are some easy fixes)

1st off, I want to apologize for an inaccurate post regarding MIDI notes hanging in the 2.3 release. After testing on 2 different machines with 2 different MIDI control devices using 2 different DAWs, I continued to get MIDI notes hanging in performance mode and I INACCURATELY reported as much in this forum. However, when moving to a 3rd system in my studio, Performance Mode worked perfectly and I got no hanging. It was music to my ears. I removed the post and it should be gone in 24 hours. Again, my apologies for the bad info.

That being said, I was able to finally isolate the cause of hanging MIDI notes in performance mode even after updating to 2.3 (on Windows machines.) : The culprit: Windows Audio Device driver latency

My Fixes (there may be others)

In Studio One, I can use the Windows Default Audio device but I need to set the Studio One Dropout Protection to at least Medium (your results might vary)
You do this from within Studio One Options/Audio Setup/Processing/Dropout Protection
image

If you are not a Studio One user or you can’t find anything related to latency or dropout in your DAW, you might try some other low latency ASIO drivers like ASIO4All (ASIO4All.org)

FWIW my system components:

  • Windows 10 Pro
  • 5+ year old Dell desktops and laptops
  • Studio One 5 Pro, Rolland ZenBeats
  • NI Komplete M32
  • Arturia Keylab 61 MKII
  • PreSonus Atom
  • PreSonus USB Audio Interface

I’m sure there are more knowledgeable people with other fixes/workaround, but I hope this can help.

3 Likes

Thanks @TMacD

Great post, this will definitely help a lot of people with StudioOne. :pray:

Thanks Edouard.
One clarification…based on my limited testing, this was not unique to Studio One. I could reproduce it in both S1 and Rolland Zen Beats (the only two VST hosts I have). It seems directly related to the Windows Audio Device driver.
I’m going to load a couple other hosts and will update this post if I learn anything new.
Thanks for a great tool.

1 Like

I’ve noticed this…

When selecting audio drivers, Reaper has a blatant warning against using the Window’s Audio Driver.

It’s no surprise to me, as warnings are not usually unwarranted.

1 Like

Every guide I read so far about DAW’s audio issues recommends avoiding Windows Audio Device driver like the plague :smiley:, and using ASIO4ALL instead, if your audio device has no ASIO embedded, that is the best options

cheers

2 Likes

Real thanks, Asio driver solved this problem :+1: :+1:

1 Like