Different sound/polyphony between mouse click and key press

When I press the key on my keyboard to play the chord (bind feature) versus just clicking it with the mouse - the sound is slightly different, thought I was going insane.

Now I see on the polyphony indicator lights on my Novation Peak… the click give me 5 notes, pressing the keyboard gives me 6 notes. Safe to say (I think) that it why they sound slightly different.

But why?

When I record each in DAW, mouse click versus click, they are both 5 notes on the piano roll - not 5 and 6 like I would expect.

Anyone know what is going on? When I hover on the chord in scaler it is only a 5 note chord.

Strange!! I am on the trial version, can anyone help please?

First thought - hanging note. Last update (2.3.1) pretty fixed it for me but I used to have “additional note” when playing keyboard “crazy Paganini style” :wink: pressing two chords at the same time for a nanosecond :wink: . Never happened when clicking. Suggestion:
a/ Reset any hanging midi clicking on "midi
Screen Shot 2021-03-22 at 9.48.21 PM
b/ Try to play your chord progression “one-finger style” and see if your hardware still detects 6 notes
c/ Drop the screenshot of Scaler to the forum - maybe you did something wild :wink: in the interface

Not sure what one finger style is but I am only using one finger on the keyboard, no arpeggio or anything.

I have restarted ableton multiple times it is always 5 notes on the mouse click and 6 notes on the key. I pressed the panic button, no difference.

Is it possible C2 is playing twice at the same time somehow?

I can see it lights up white at the bottom of the key on scaler when you press the keyboard, but click the chord with the mouse and this doesn’t happen.

Hi @Acidizer

are you sure there is no other instrument listening to all MIDI input? You can try to mute everything else to find if the extra note is played by Scaler.

For some synths you have to disable the internal MIDI routing. Otherwise, the note you press will always be sent to the output, it does not go through Scaler and can’t be filtered out.

I am using Roland Fantom as the keyboard, Novation Peak is what I am playing.

I tried local off on Peak no difference.

OK when I press all the other (non binded) keys on the keyboard, the Peak is showing 2 voices used instead of one - unless I force the Peak into mono mode. Change back to poly mode and it uses 2 voices on one key.

Seems like a raging clue.

Novation Peak doesn’t play nicely with local off. Have a look at #2856 here https://shrtm.nu/NCBR
Check your Arp to Midi setting and local off envelope, ensure you have the latest firmware. That keypress from your Peak is coming right back to it.

I had a similar “extra note” experience on a W10 Dell laptop yesterday after I installed 2.3.1 but after some testing, all is good now. While my situation was the same note all the time, this might be helpful.

Short version:
Issue: F5 was being thrown and hanging every time I opened the Chord PaneI. Fix: shut down, disconnected all my devices, restarted and everything was back to normal. I then added all my devices and things have been stable ever since.

Long version
When I’d click through the different pane selectors 1-5 next to the Scaler keyboard, 3. Chord would throw a F5 and hang the note. The same thing would happen when I used the keyboard Control+3 to toggle to that pane or if I’d right click on a chord and select edit. EVERY time I’d make that selection, F5 would play and hang.

After Isolating the problem to my Dell Laptop (My other 2 machines are desktops and were not having the same problem) I disconnected all devices, rebooted and everything was back to normal using just the laptop keyboard and track pad. With a huge sigh of relief, I started attaching my other devices (keyboard, mouse, NI M32) and everything was back to normal.

Sometimes you just need to ask the # 1 support question… have you rebooted? :slight_smile:

It is a midi problem some how unfortunately my brain shuts down any time midi routing is mentioned.

I have a 5 pin midi cable from my keyboard to my Peak to play it when ableton is off. Unplug this and the problem is fixed and I can still play Peak with the keyboard within ableton (USB midi). Problem solved? No! :frowning:

When I record into the sequencer it plays back the notes as long as the red record button is active. Turn that off and the Peak wont play the notes back.

Strange… can anyone help with this?

If I can get this all sorted I can buy it and use it without all these headaches. I know it is my fault for not understanding the midi routing concepts.

Currently, your hardware setup is a ‘threesome’. Your keyboard (source) is sending the same information (key press ie. C4) to two recipients (Peak and Computer) at the same time. This is how you wired it. C4 goes via USB to Computer and, at the same time, via 5-pin to your Peak. Computer (Scaler) is transforming C4 to a chord (ie. Dm7) and sends it to Peak. Therefore Peak receives at (almost) the same time 4 notes that constitute Dm7 and (original) C4 - that’s why you get 5 notes instead of 4.
When dealing with hardware, get ready to plug and unplug cables. It’s just the way it is. If disconnecting 5-pin is a problem, think about getting 5-pin hub (with switch on/off button) and put it between Keyboard and Peak (this way you’ll have best of two worlds).

Yup, it’s like that in Ableton. The button name is “arm for recording” and it works like that. Nothing strange here :slight_smile:

No shame in that. Everybody is a noob at some point in time :wink:

You’ll have fun :slight_smile:

No I mean the actual record button. Not the red arm button.

Which mean it will not play back unless it is recording. Doesn’t play back when it’s only armed.

Turn the record button off and the sequence keeps on playing in the sequencer but the sound stops.

There is probably an obvious answer to that behaviour, for those who use Ableton as primary DAW. Maybe record button does something implicitly. Try asking the question on Ableton user groups/forums - you’ll have more chance to find someone with similar setup and get better help.

I have reviewed again the screenshot you have published in this thread and I see couple things that seem strange to me. It’s not neccessarly wrong - just different from what I do.

From the top:

  • Internal instrument (felt piano) is still active in Scaler - when using external instrument I would set it to ‘off’.
  • you’re forcing monitors on the tracks (‘in’ instead of ‘auto’) - I would go with ‘auto’ - when everything is set up ok, sound will be generated.
  • Scaler related tracks (2 and 3) are not activated - I would activate those.
  • Only one track is “armed for recording” - I would arm both

I believe the problems you are experiencing are not Scaler related.


The track wasn’t activated, what a dummy! It works now thanks!!

Now I have an ocean wave regularly, sounds like the game Outrun… Quite relaxing lol and kind of goes with the music :star_struck:

Also the felt piano was playing underneath like you spotted, sounds better now :+1:

Now if I could only get that extra note on the keyboard bind sorted it would be perfect. Do I really need to keep unplugging the 5 pin midi?

Yes you do :wink: Try to get second hand 5-pin hub with on/off button - it’s a game changer :laughing: Lots of people selling their 5-pin stuff for nothing this days.