Double input of chords

When I drag chords from Scaler into my D.A.W (Mixcraft Pro Studio) I find that the same chord is duplicated, one underneath the other. I delete a chord and there is an identical one underneath so I have to delete again before the bar is empty. This is a pain if I want to chop up the chord as the chord underneath remains its original length as it was dragged from Scaler2. Any solutions?

2 Likes

Just want to say I have the same issue. My DAW is Cubase 10.5 Pro.

1 Like

in reason 11 studio this action creates 2 midi tracks

Hopefully this will be solved in the next update on Sep 9th.

Hi @samuel_beliveau, @regbower, @s-a and sorry to hear that.

I have been testing on Mac 10.15.6 with Cubase LE AI Elements 10.5 (setup : 44100 Hz and 256 samples).

I have tested with : Scaler version 2.0.9 with VST and VST3 versions of both Scaler2 and ScalerAudio2 I have been dragging single chords, multi-selection of chords, entire progression, and midi capture and in all cases I have been able to delete a single note of a chord (clicking on the piano roll on one note and deleting with “delete” key) without having the same note “underneath” also I have been able to resize a note from the chord without having the same note “underneath”.
Could you please give us more details about your configuration and if possible a repeatable process to replicate the duplicated midi clip issue.

Which version of scaler (VST or VST3 / Scaler2 or ScalerAudio2 ) is having this issue ?
Is it happening on a fresh new session?
Any kind of MIDI drag ? one chord, a multi-selection of chord, an entire progression or MIDI CAPTURE ?
Are you dragging to a specific track ?
Any information that you think can help replicate the issue is welcome.

Thanks,
Cheers,
Paul

Hi Paul, I have the issue using:

OS: Windows 10
DAW: Cubase Pro 10.5.20 Build 179
VST: Scaler2 v2.0.9 (I’ve tried with both VST and VST3) (I do not use ScalerAudio2)

It’s happening on a brand new cubase project. The simplest way to repro the behavior is:

  • Create a new instrument track with Scaler2 (VST or VST3, doesn’t matter)
  • Select C major as the scale
  • Drag and drop C maj chord on the Scaler2 track you’ve just created

At this point, I see this:
cubase_scaler2_issue

if I delete the top-most midi event, I see the same chord below:
cubase_scaler2_issue_2

Let me know if you need more information.

Thanks.

Not sure if it’s helpful, but here’s the history of commands in Cubase after I drag-and-drop the chord:
cubase_scaler2_history

It means that when I click undo (in cubase), one chord is removed and if I do another time, the last one disappears.

In my previous post I stated that the issue arises in the scaler2 track, but in reality it does the same in any instrument or midi tracks.

Here’s another batch of info:

  1. Sometimes it doesn’t double the midi import, sometimes it does. In the following images, the two red circles will duplicate the midi, while dragging the C chord in green will behave correctly (only one instance)

  2. Sometimes, let’s say 10% of the time, what I said above will not duplicate the chord. This is somewhat random… maybe a race condition or something?

@luapmartin, I guess it’s all I can say for now, hopefully all of this might help you.

This has been an issue for me also since version 1. I have flagged it a couple of times on this forum. I’m using Cubase 10.5 Pro. I would say this happens 80% of the time. It’s easier to work out the chords in Scaler, then enter them manually via the Chord Editor in piano roll.

1 Like

Still happening in 2.1.0

Though maybe not directly applicable to this scenario (this is more related to capture specifically), double check to make sure that you don’t have overlapping zones set on your midi controller. Overlapping zones will send duplicate notes and will also cause more frequent midi note input sticking.

@g101 Welcome and thanks for tip

@g101 This bug occurs even when there is no midi controller connected to my computer. I’m not sure what overlapping zones are, but I don’t think it causes my issue.

Agreed, I don’t think it’s related to your situation with regards to a midi controller’s input. Zones are often referred to as keyboard splits or layers (some DAWs have internal controls for zones too.)

I think you might be seeing doubling due to midi input assignment creating a midi loop which may include scaler midi events even if they aren’t being received through an external midi device. I’ve never seen duplicate notes from scaler (different DAWs though, however the plugin code is the same.) Also, since it seems that the dev test configurations in cubase aren’t seeing duplicates either, it indicates that there’s some sort of difference in the cubase midi configurations that’s causing a midi loop. Possibly related to your midi through/thru assignment in conjunction with active midi ports. Audio interfaces with midi ports will have often both DirectMusic and Windows Midi enabled simultaneously within cubase. It’s possible that a combination of midi through setting and/or assigned ports are creating this loop.

Not very familiar with cubase but it does have a comprehensive MIDI implementation which can sometimes cause problems for users, check out the support article in the link below:

“* Double or triple recordings of the same MIDI events due to using different driver architectures at the same time”

https://helpcenter.steinberg.de/hc/en-us/articles/206366824-MIDI-issues-on-Windows

@Ben you can delete duplicates through MIDI>Functions>Delete duplicates. If that does not work, make sure that the notes aren’t split between two MIDI channels, both doubling and non-working ‘delete duplicate’ function is generally caused due to midi input port configuration issues within cubase.

Thanks for the explanation @g101 . Maybe there’s a relation with what you’re saying, but I will have to research what you said further.

Not sure if it’s a good comparison, but I don’t have this problem with Omnisphere 2.6 when capturing a few bars of its arpeggiator and drag-and-dropping the midi on my tracks. So if there’s a problem with my Windows configuration, it’s only affecting Scaler for now.

1 Like

I think you’re right, the midi from Ominsphere arp would be doubled otherwise I would think too.
Also since you’re not seeing it happen every time you drag midi from scaler, it really seems like it can’t be what I was thinking.

Just a friendly FYI that it’s still happening in 2.1.1

Not sure if it’s on your radar, but just wanted you to know.

1 Like

Hi, I had pending to report my test about this drag duplication issue, which happens to me quite frequently. Hope this helps a bit. Cheers!

Drag duplicate issue (video capture below)
(double input of chords)
Replicate test
Scaler 2.1.2
Reaper 6.1.4
Windows 7 & 10‎
06-‎Oct-‎20

Carlos

I use Reaper, 6.1.4, too and until now was convinced this was a problem with Reaper. In fact, I believe it was always an issue, maybe since Scaler 1.x, but never thought this might be Scaler. Now, I am sure it is. Not a big problem, rather an ennoyance but would be great if possible to fix it.