Double notes / micro notes issue - recording and drag and drop

I’ve been working with 2.7 quite a bit now in Bitwig and Cubase 12. In addition to the hanging notes problem there is an doubling of notes and micro notes issue that has been is Scaler for quite some time. It seems to almost be gone in some versions but it’s back now for sure.
The issue is mostly using Performances but I am still testing. Whether recording the MIDI or Drag and Drop Scaler produces doubled notes i.e. notes on top of each other. Not all notes but many. These are hard to spot as you have to move the head or tail to see the note underneath. That makes clean up a chore although I think I have a clean up with Logical Editor in Cubase that might help.
The micro notes are very short notes at the beginning/ending of one chord to the next. These are annoying because they can cause long notes to stop ringing out and sometimes stop the chord completely. I have a Cubase fix with Logical Editor that will remove these but I need to export the MIDI clip from Scalar to do it.
I am still testing but is anyone noticing this? Not sure it’s directly linked to MVO as I’ve seen it before this update.
I’ll post some screen shots tonight.
My system iMac 10.15
Cubase 12
Bitwig 4.4

Here are some screen shots to illustrate -
Double notes -

The “Micro” Notes -

I’ve noticed this too. I think a shortcut with a logical editor preset is right way to get rid.

I’ve now got 2 logical editor presets that just gets rid of all the extra notes. Both work perfectly. The unfortunate thing is it needs to go on MIDI files so I need to commit at some point. And it means no working in Bitwig or another DAW which I like to do.

Yep…been messing with them for a couple years now and went down some deep rabbit holes. I came to the conclusion it was a function of quantizing and the fact that I was triggering fast tempo perform chords directly (either by hand or using midi sequenced). I was also doing a lot of recursion at the time where I was feeding Scaler it’s own performance midi. Here is a thread on that.

This would generate a huge volume of midi with small notes. I assumed that the transistion from one perform chord to another, sometimes occurred just off beat and resulted in notes that were not finished playing or were just starting. In my scenarios, I often found that enabling Play Quantize helped keep things clean.

So that being said, How are you triggering your midi? Are you using Scaler Playback, Triggering chords directly using bound keys or are you using midi sequences? Do you get the micros in all those scenarios?

Also curious about the capture process. Do you get them when you

  • Are using a midi capture track in your DAW
  • using midi capture from w/in Scaler
  • Drag and drop performances from Scaler

Also, have you noticed any correlation to speed of performance and presence of micro notes?

FWIW, I did a 4 part video series on Chord Duration & Timing. Part 3 has a piece about feeding Scaler it’s own midi.

I think it’s been there as long as I have been using version 2. I need to test further but I think it is primarily in Expressions. I don’t believe I see it in just chords. [Just tested and it’s still there with just chords]
I never use MIDI capture.
I usually have Scaler synced to DAW without trigger notes.

So if I record the performance as MIDI it’s there.
If I lasso all chords and Drag&Drop it’s there.
Happens at all speeds .5, X1, X2
I’m working on a piece now so I will be experimenting.
I just did a test and drag&Dropped one chord at a time with Performances and it was the same. Then I Drag&Dropped just the Pads with no Performance and still got the Overlapped notes and the Micro notes. The Monitor showed the Micro notes as 0 length but they still seem to have a note on attached to them.

Cubase is a life saver as I can run the MIDI monitor and see the Overlapped notes and delete those as well as the micro notes.

1 Like

Interesting…I could have used that kind of monitor. I probably had notes I never actually heard or saw.
Looking forward to your testing results.

Hi @jamieh

thanks for reporting we will have a look at this.

2 Likes

I think the overlapped notes are caused by the MVO. I tried turning off MVO and did not get overlapped notes. I still got the micro notes. @davide

FWIW, A post from last year on the micro note topic Scaler 2.5 adding in very short notes in Performances - #4 by TMacD

Looks like I was in on that one too. Hasn’t kept me from using Scaler.

Yeah…saw that. Nothing we cant figure a way around.

Hi @jamieh

the duplicated notes can be related to the Multi-Voice-Output. If you record the MIDI from Scaler’s output and have MVO turned ON then Scaler will send out the notes on the channel 1 and on the note’s channel.
If your DAW is recording from all channels then you will have duplicated notes but they should play on different channels. You can get around this by telling your DAW to record only from channel 1 or filter out the unwanted channels during/after recording.

In your first screenshot those duplicated notes seems to all be on the same channel (1). Not sure if this is how you recorded them. During my testing in Cubase the duplicated notes where recorded on different channels. Do you have a specific chord-set/performance settings which triggered this?

Regarding the micro-notes with zero length, we found a way to prevent them from appearing.
This should reduce their number significantly.

There are still some edge cases where short notes could show up. For example when recording the output of Scaler with DAW-Sync. Scaler might have a note to play just before a beat, but as we pass to the next beat, we change chord which stops the notes of the previous chord. If the DAW received the noteOn just before the chord change, a tiny note will exist. This is what @TMacD is referring to and can be mitigated by using quantization as it prevent those off-beat notes and align them on the beat.

Apart from this specific case, the next update should improve the overall situation.

2 Likes

thanks to have explained with appropriate words what I’m also experimenting, but I was unable to explain :woozy_face:

this issue is long-standing, I think to remember from the first release I used

BTW, something similar happens with Keys-Lock green keys

my system is different: no MMO involved, Windows 10 Pro and Ableton Live 11 Standard