Dragging Arpeggiated notes don't line up in DAW - partially solved

UPDATE: This is my wokaround for Reaper: Scaler Arpeggios In Reaper](https://youtu.be/nt3XzVuGPEk)
Hi. New user so might be user error but grateful for advice.

I have created a chord sequence - just selected Rock1.
I then dragged to my DAW (Reaper) with note values set to whole notes (4 beat).
That works fine. (the piece is in 4/4 by the way).

Then I chose arpeggiator at 1/4 value and dragged the midi, again with note values, this time set to quarter note (1 beat) - with me so far ? :grinning:

The problem is, that the first midi clip is 10 bars long and the second is nine and three quarters.

The arpeggiator is set to “up” and only gives 3 notes, which means the next bar starts too early.

Help would be greatly appreciated.

EDIT: The arpeggiator works off the number of notes in the chord, so if you have a simple triad, you’ll only get 3 notes. It would be good if the chord indicated how many notes it was using. Does anyone know a workaround other than having do some mental calculations on the fly and have to edit every chord in the sequence …


Hi @Mykyndryd

You are right, this is what is happening.

This is a good suggestion, it is not always clear how many notes you are going to get. We will have a look if we can implement this in the next update.

Thanks for reporting and helping make Scaler better.


Thanks Ed.
It might be worth looking at having a meter setting on the arpeggitor (and a time sig) so that it can work out how many times to trigger the arp notes per bar (chord), and that would make it completely independant of how many notes were in the chord itself. As I say, that would be a complete game changer.

For now, feeding the chords back into Scaler as a midi sequence seems to work ok for me (per workaround).