Editing chords: changing velocity of individual notes

I am on Scaler 2.7. Trying to edit individual chords and change the velocity of individual notes does not seem to work. It seemed straight forward in a video demo of scaler 2.1.
Also my edit screen does not show the “undo”, “redo” buttons. I’m wondering whether there were changes in 2.7 that affected this.
(Screenshot attached)

This has been reported so it is a known issue and will no doubt be addressed in an update. The velocity is accidentally tied to the new velocity slider in preferences. A work around is to open preferences and move the slider to the velocity to what you want then click on the key you want to change. You can do that for each key in the chord if you want them to be different velocities. You can do this while the preference window is open.
It’s not ideal but it will be addressed.

Undo buttons on the lower left.

1 Like

Yes, thanks Jamieh. I tried this and I change the slider in the Preferences and then click on the required note, and yes, it does take on the slider value. However, the actual volume seems to still be common between all notes of the chord. So they’re either low or high.
Anyway, I hope this will be fixed soon to function as in 2.1 as you mentioned. Thanks again ,

By the way, any idea where the buttons of “undo”, “redo” are now? (I mean in the Edit chord mode).

If you click on the SCALER log you will get two options: UNDO LAST ACTION and REDO LAST ACTION.

Bottom left of the screen - that’s where they are always anchored now for easy access.


Thanks. Yes I found them now :slightly_smiling_face:
Regarding the velocity issue, I still think it’s a bit buggy. As I mentioned, the velocity value DOES change on the screen for the individual note by moving the slider and clicking the note, but then all notes of not only the one chord but the whole row will take up the new volume level (on listening). Moreover, the listening levels become different from when auditioning the individual chord to when pressing the play button (or is this intentional anyway?).
Anyway, I’m sure this will be fixed in a coming update. Just thought I’d mention it.