Extra and missing notes

Hi, I’m trying to make a midi instrumental in Pro Tools. If I send the midi output of Scaler to my Nexus track, I get one set of notes with some extra notes that I’m not sure should be there(super short notes at the end of bars), and if I use midi capture, there are big notes that have shortened to super short notes. I tried changing a lot of settings, trying different swings or no swing, etc.

I’m using Windows 10, the latest subscription Pro Tools software, and Scaler 2.6.0. My session is 24 bit, 48K.

In the pic, the first track is from routing scaler to the track, and pressing record. The second track is from midi capture. Neither one looks right based on what is playing on the scaler gui, and playing back the midi doesn’t sound the same as when recording it or playing it from Scaler.

Hey Kevin

Can’t see your Scaler setup but it looks like you might have Perform Mode enabled when playing back your original midi. If you took Scaler’s Perform midi and ran it back through Scaler, settings in Scaler can impact the playback (and the resulting MIDI capture). The most likely scenario is Perform is still enabled, but it could be other settings you have tweaked. To be sure, you can clear the state before you run your midi back through Scaler.

I do a lot of Scaler to Scaler midi stuff and I suspect the tiny notes you are seeing are related to how Scaler does Perform mode playback and internal quantization. While it might seem like a “bug”, it is more likely a timing/alignment issue as Scaler opens and closes “playback windows” (my term not Scaler’s) and truncates incoming midi that does not fit w/in the window.

It is a fairly opaque topic so if you are not familiar with how settings like Expression Resolution, Chord Duration, Play Quantize To, Play Quantize, Latch interact with each other, you can find some info in some of these videos:
Search results for ‘#tutorials @TMacD in:created’ - Scaler Plugin - Community Forum

The 4 part series on Chord Duration is probably a good place to start.

[looks like ver 2.6 might have an issue with Play Quantize so hang tight on those topics]

Hope that helps a bit.

Thank you for the reply, but why would it matter if scaler is on perform mode? The scaler track is muted and isn’t connected to the ‘MidiCapture’ track in any way. I needed perform mode on in order to create the midi. Then I just dragged it to an unrelated track to see and hear it. But it didn’t create it right.

The ‘ScalerRouted’ track is connected to the scaler track(Scaler outputs midi, so I input it into that instrument track). It worked better, but still not right. You can see there is a super short note at the beginning of bar 3. Then look how messed up bar 3 is on the ‘MidiCapture’ track.

This is my scaler set up:

Of course it has to do. Scaler will do the interpretation of the interpretation. Please try removing the interpretation and let us know if you still have the same problem.
In fact, sometimes I try to have a rendering set and see what Scaler returns, but for unexpected creative functions. Sometimes nice coincidences happen. But it is not normal behavior.

Hi, I finished watching those videos and they are very helpful. I learned I might be able to just drag what I’m hearing to the instrument track. But the videos didn’t seem to cover my situation because you didn’t really bind a note for each chord, or use midi capture, or route scaler to another track, and I still think that when I bind those 4 notes to Scaler(they are greyed out in the pic so you can see they are bound), and play it, there should be some way to capture the midi I hear without it being messed up. Midi Capture doesn’t capture what I’m hearing, and routing to my Nexus track doesn’t capture it. So there is no way to capture it besides possibly dragging each box to my desired track. It seems like a bug, because even if it’s messed up, why aren’t they both messed up the same way?

I did try what you said, and turned Perform off, but the midi is already on my Nexus tracks, so the sound didn’t change. If I unmute Scaler, and turn Perform off, it doesn’t play the pattern I like, and so it seems like there is no way to capture the pattern (except possibly dragging it to the Nexus instrument track with perform on)

Still trying to track to what you are trying to do and I still suspect it is simply a setup issue. There are at least 2^4th record/playback variations when you are setting up Scaler in your DAW so lets start with the basics.

1st - yes, you can drag chords or sets of chords (patterns) directly to a track on your DAW and you will get all of the midi notes AND any other performance or settings MIDI. If you have a performance mode turned on, that midi is automatically written to each chord. This also includes certain settings such as chord duration. It is a fast and easy way to get specific midi into Scaler and I use it almost everyday.

This might be more basic than you need and I’m not trying to drive an external instrument, but you might try this as a starting point so you fully understand how Scaler works in this setting. Unfortuantley I don’t know your DAW or Nexus so caveat emptor.

  1. New song in your DAW
  2. 1 track - name it T1
  3. 1 instance of Scaler on T1
  4. Set your Instrument Output on T1 to Scaler (this is Studio One language…it is the processor/instrument of any midi on that track
  5. Set your Instrument Input of T1 to your midi device (this is what the track listens to for midi data)

image

Now, if you play your midi device you will hear whatever you have Scaler set to but the record function in your DAW will only record what notes you play on your midi device. It is not listening to Scaler’s processed midi. When you playback that midi, you will get one of 3 things:

  • A Scaler Performance - if you have that enabled
  • Scaler Chords - if bound to notes you played
  • Just the notes - if bind is not on
    This is happening because Scaler is processing any midi on T1

However, if you play the Scaler interface directly (including automatic playback) with your mouse, you will probably hear things but you will not see any midi activity in your DAW and you will not record anything on that track. There is no midi being generated by your standard midi input devices and that is what T1 is listening for. You can however, drag chords directly to a track and you will get any midi associated with those chords. You can also enable midi capture, play what ever you want on you midi device or with your mouse and then drag all that midi to a track. Scaler does not miss anything coming through Scaler in it’s midi capture.

Now, if you want to record the output of Scaler, chords, patterns and or performances we need to make a change to your track setup (at least in Studio One)

  1. Set T1 Instrument Output to None
  2. Set T1 Instrument Input to Scaler
    If both are set to Scaler, a nasty feedback loops occurs…as it should.

Now when you hit record and you play from WITHIN Scaler (not from your midi device), you will record whatever you play because Scaler is sending midi as a device to your track. However, you still might not be able to play your midi keyboard to drive Scaler.
[this will vary by DAW]
In my case, I need to tell Scaler to listen to my midi device directly. For me this is done w/in the Scaler wrapper UI under MIDI inputs.

Now, regardless of how I play Scaler, with my midi device, my mouse or with Scaler playback, everything is captured without missing a beat. Including any truncated notes that perform mode might generate as it tries to use midi that is not quantize aligned.

Once you get this working as you expect, I suspect you can just load Nexus and bind it to the Instrument Output of T1 and set Scaler’s sound to none. Now Scaler drives Nexus and you can record that midi.

Understanding these setup variations should give you what you need to work with external instruments to create and capture whatever you want.

Good luck.

1 Like

Here is a new one. What I want is what is in the “Dragged” track.

The “Routed” (and “MidiCapture”) track adds so many notes just because I have it bound to some midi notes. I thought it was necessary in order to tell it how long to play each part of the progression. Now because of your videos, I know that if I don’t bind those notes, it will play properly based on my chord duration setting. You can see in my scaler screenshot, I painted 1 note on each greyed-out chord. But for some reason, instead of telling scaler to just play the pattern for that long, it tells scaler to play a completely different melody.

I still think the “MidiCapture” track should have the same midi as the “Routed” track, and it looks like a bug to me that the note lengths are so different.

Maybe it’s just a Pro Tools thing.

Hmmm…the plot thickens. But it does seem like you now know how to get what you need…which is good.

As to the basics, when it comes to midi, Scaler basically does 3 things.

  1. It generates static midi from it’s internal patterns based on the settings you choose and writes that midi to your selected chords.
  2. It generates dynamic midi from inputs (keyboard or playback midi on the Scaler track) based on the settings you choose
  3. it records it and formats it so you can drag it to you DAW

That pretty much it. Any “different melodies” are either a function of those things, or function of your external instrument (not likely you DAW)

A couple notes:

  • You mention something about "greyed out keys: You know that those grey keys only tell you what notes are not in your current scale. They do not change anything about how Scaler responds to your inputs, playback or performance settings.
  • On your “painted notes” point, bound notes don’t play Patterns, notes play chords (or the performances attached to that note & chord)

There is nothing here that feels like a bug to me, but I’m not sitting in your studio.

If it is a “bug”, it is worth replicating so dev can look at it. If it is something else related to your setup, it might help others. Maybe someone with Pro Tools and your instruments might be able to help.

Good luck

Most of these grayed out keys are definitely in the scale.

image

image

According to every tutorial I watch, it means they are bound keys, and they are just supposed to play the selected performance/phrase/melody etc. This guy in the below video has notes painted on the bound keys just like mine. It doesn’t start adding extra notes to the performance, and his midi capture probably actually captures the midi that you hear and see playing instead of stretching out some notes and turning others into little phantom notes. But he is using Logic, and an older version of scaler. It seems like in the video, the bound keys just play the performance. If mine worked like his, all 3 tracks I showed you would be the exact same notes. - Scaler 2.2 Bass Mode | Melody Mode | Swing | Navigation | Grouping - YouTube

We don’t have the latest tools in our arsenal but reaching out to one of the composers to check, may take some time but will come back to you. FWIW haven’t had any of this type of feedback from tools users…

1 Like