Fails to open after 2.8 update

Try this -

Thank you for the suggestion; not much has changed, I’m afraid… I’m not getting the empty black window but the GUI still does not open, There’s a differently worded warning popup in Studio One and a hard crash in LIve 11, although this time around with a proper error message instead of a CTD.



Weird. I’m on Win 10, Live 11 and (as of this morning) Scaler 2.8 and all functions as it did.
Are you picking up the VST3 in Common FIles ?
What video card are you using? (I’m on AMD W3100 which has always been fine)

It may be worth looking at the Live crash logs (I presume you sent the zips to Ableton)

(Later : quick thought are you on Win Home or Pro ? Almost certainly nothing to do with it, but curious))

Hi panda, I’m running Win10 Home and the GPU is an Nvidia GTX 1660.

VST2 and VST3 both fail to open for me, and unfortunately the problem is not limited to those two DAWs I mentioned; Cantabile 4 also crashes to desktop e so does Bluecat Patchwork. So none of the plugin hosts I have installed can apparently run Scaler 2.8.

As a workaround, I have rolled back to 2.7, which works fine for me, of course as soon as I try and reinstall 2.8 the constant crashes are back.

I’m at a loss.



EDIT: more configuration details:

HP Pavillion 11th gen Intel i7, 32GB RAM
Audio: Focusrite ASIO @48KHz 256 samples
Active MIDI devices: NI M32, Novation Launchcontrol XL
Software: Ableton Live 11.3, Studio One 6.1, Cantabile 4 - latest updates

Thanks for the reports, we are looking into it. It seems to affect only some users

I don’t have the issue here, I am able to run Scaler 2.8 on Win 10 in various hosts, Reaper, Studio One, Cubase… so feel free to add as many details about your config as possible. It will help diagnose the issue.

Did you install the optional extra sounds when installing Scaler 2.8? I found that it crashed Reaper every time until I finally reinstalled it with the extra sounds. I don’t really need them, but it fixed the issue for me. Worth a try.

1 Like

This worked for me Thanks for the info!

As weird as it sounds, that did the trick; thank you so much!

It’s still probably something the devs might want to look into for a future bugfix, but in the meantime I can live with the extra 600MB of sounds I’m probably not going to use :grin:

Take care!


Unfortunately, I am in the same boat…


mmm maybe because I refused to install the extra sounds?
I always refuse that, so devs put a curse on me?

Well, I wait for the fix

I thought you did the Beta.

nope, I had no time doing it

Did you try the sounds suggestion? Maybe go back to 2.7 for now. Although you aren’t using it much, right? Switched to EXKeys2 for the most part?

I usually delete all sounds at each Scaler version and downloading 1 GB needs time, so I’ll wait that they fix the issue

about EZkeys 2, I am using it more because I can build a cool basis to jam on in seconds (for example I had a lot of fun yesterday jamming with my Hammond on a blues song), but I still use Scaler to build series of chords because I think it’s faster and easier

Then you can jam without a keys lock feature.

Yes, actually I use Bitwig’s Harmonize coupled with Key filter: this combo often works very well, and offers more playable notes compared to Scaler

I am unsure about, but it seems to me that Scaler gives you many fine notes when the series of chords is simple; otherwise, if the series is complex (many odd chords) the notes offered for solos decrease

I’ve only used something like this a couple times in Cubase that I use for films. Cubase has a chord track that works perfectly to shift wrong notes to correct notes.

Fixed, new installers are going up on PIB. I’ve asked them to confirm when they are live.

1 Like

I have the exact same issue. Studio One 6 Pro here.
I tried to disable openGL, now the app doesn’t crash. But look what I see now!

Yes same here with Cubase Pro 12. Crashed 3 times. Reloaded software this time with the extra sounds and it loaded properly.
But now the program is erratic. I am not getting good results. The melodies produced are highly repetitive. Not good so far. Could be user error, but it does not feel right somehow.

I had this problem as well and did a bunch of testing.
Bottom Line:
You must install the extra sounds and you must install them in the default location provided in the installer. Not installing the extra sounds or installing them in location other than the default location results in the problems listed above.