Fails to open after 2.8 update

I had this problem as well and did a bunch of testing.
Bottom Line:
You must install the extra sounds and you must install them in the default location provided in the installer. Not installing the extra sounds or installing them in location other than the default location results in the problems listed above.

This is fixed and new 2.8 installers now live at Plugin Boutique.

1 Like

2.8.0 is not the same number as before?
Do I have to wait more time?

Ciao Claudio, we just had PIB replace it so the one you see on the PIB account (2.8) is the fix. Fammi sapere se c’è un problema!

Ciao Davide, I was about to ask the same thing because the 2.8 I downloaded last night didn’t seem to work either.

So I downloaded another fresh copy off of PB (still shows up as 2.8), deleted the earlier plugins AND the entire folder in the Public documents where the sounds are stored (it’s the deafult location), and then did a standard installation and…I’m afraid to say the issue is still there for me. The workaround of installing the extra sounds is still viable, thankfully.

Anything else I could try?



well, I’ll wait more, because downloading 1GB needs an hour :cold_face:

not a problem to me anyway, because I just search for fun in music (and other arts)

That’s worrying, either it’s not fixed or PIB didn’t correctly upload the installer (we replaced it so showing up as 2.8 is correct).

Claudio can you try it and let me know if it worked for you?

If it can be of any help, I have done an MD5 comparison between the installer I downloaded this morning and the one from last week: they are identical. So it’s probably just a matter of PB not having deployed the updated 2.8 to the user accounts yet.

Edit for reference:

Scaler-2.8.0.exe - 1119861584 bytes
MD5: 4fb41a645011466684ca0e2020392815
SHA1: 8c624a414fb010829dc5892b9bc58baecb6de8d5
SHA256: 7ef84a96e69410db33b3041abf77b62cc450320b288062c9036c1c63b82eb0b0
SHA512: 15112ac7898c4e232f9fc9dfc55dbbd1b84a0db501aec9bb2193af8da5e1e81c134eb9e4b7ba7cf714dfe4369028a2bbaaa86032907d249d8d49b1d9f5ba49ae


Bad practice for a developer to change program and not change version number.

Hi @vulpes777

I think you are right, you might have re-downloaded the same version.

However, I did check the download just now from my Plugin Boutique account page and they are the updated version. (MD5 Scaler-2.8.0.exe - 462845e02332c15fa2dbcbd7c1759e45)

Maybe give it another try.

Hi Edouard,

I can confirm the installer I can download from ‘My Products’ is still the same - and that’s the only page where it shows up, as the entry in ‘My Updates’ was removed when I updated to 2.8 last week.



Thanks, we will get this sorted.

Maybe that the PB AI sees the same number and refuses it…
The good (still to see) and the BAD of AI
:stuck_out_tongue_winking_eye: :rofl:

All fixed, PIB had not changed the Scaler 1 > 2 Update installer, only the new Installer. They have confirmed that everything is up to date now.

1 Like

Haha okay, this explains why the updated installer didn’t show up for me.

I can confirm I can run 2.8 with no crashes now. Many thanks for getting things sorted out and also to @DanDiplo for the temporary workaround.

Keep up the good work!


I confirm that it works now

but the forgetfulness issue remains: every time I reopen my DAW the Section C is un-looped and un-selected

Not forgetting on my Mac. @James Can you check this on PC please?

I can add that this happens also closing just the project, not the DAW

Hi @ClaudioPorcellana

What version of Scaler 2 specifically are you on? 2.7 or 2.7.x? and what version of Bitwig?

the latest 2.8 and bitwig Studio 4.4
but I suspect it happens with old projects where a previous version of Scaler was used
Tonight I’ll do a test with a fresh project