How to live play Keylocked melodies in tune with pattern and chord changes without Keyswitches triggering sounds?

Hello Everybody
First of all - really great product and really great team!!!
I have the latest Scaler 2.8, windows11 Cubase 12.6. I bought the scaler courses too and searched numerous forum posts and youtube videos but can’t get this to work.
I have this configuration and am trying to achieve the following:

  1. The leader instance of Scaler is setup on a track with 5 patterns in Pad mode (sync DAW is off and all is is triggered via keyswitches and chordtriggers in the Midi track of this scaler instance).
  2. This scaler triggers another Kontakt instrument and Scaler’s internal sounds are off. All this is working very well and as expected.
  3. Now I set up another instance of scaler which should trigger the same pattern and chord changes and to control an instance of BBCSO from Spitfire to allow me to freely play some melodies over the ongoing performance on the other tracks. To avoid wrong notes I have enabled keylock “Scales Mapped Notes only”. This allows me play mostly proper notes (can this be optimized?) but also triggers the chords in BBCSO - which interfere with my live playing…
  4. If I try to use only the last 2 chord options from Keylock and use the keyswitch (F#) to mute the chord playback this works but I feel that now the keylock also stops changing as per chord and scales changes and I get more wrong notes …
    Do I miss something - what is the proper way to make this work?
    Would really appreciate your kind support and guidance
    Thanks a lot

Hi @DesertMatt

Have you tried changing the octave of the bound keys so that it is away from the melody keys? This tutorial may help Changing the Bound Keys

Dear @ed66
Yes thank you - this was also done - as per your guide only!
I shifted the whole thing (pattern and chord bindings) up to C5 as the Cello from BBCSO ends at B4
As I have written, the chords can be muted in the last 2 Keylock (Chord) settings - but then I can’t see the keylocks on the virtual keyboard shift according to the pattern and chord/scale changes of my patterns getting triggert in PAD mode - I feel I’m getting many more wrong notes than in the first 3 Keylock modes but in which I can’t mute the chords…

Thanks @3Dogie
But I don’t understand what you mean exactly? Could maybe please elaborate a little bit more?