How to Make scaler2 show its GUI

I have Ableton live lite, but attempting to activate Scaler2 never shows the Scaler GUI.

Any advice?

What do you see? Blank or black screen? Try turning off OpenGL.

No main GUI screen found and the Ableton Info View shows a blank screen.
I did turn off OPEN GL, with no improvement.

We still don’t know what computer and OS you are running. After you installed did you reboot? Are you using the VST3 or VST2 version of the plug-in?

Sorry for the delay. I re-booted the computer.
But still no GUI for Scaler2.
Using Windows 10 64 and (maybe VST3).

I was using Ableton Live lite,.
Now tried with DAW Waveform12, same lack of Scaler2 showing its GUI

I’m sure you have done this, but if not it may be an idea to go back to the start and double check the Scaler version and whether the VST3 is compromised in any way. You can do the latter by taking Live out of the equation.

It may be worth having a look at the following to check the file and stand alone operation.

Thanks, panda. I will be checking!

After many tries, I found that Scaler 2 could not be activated after its original splash screen was clicked out of the way using the upper right hand “X” on the splash screen.

However, The “Close” button did properly finally activate Scaler 2. This was misleading since “Close” could be interpreted to mean “stop the access to Scaler2”.

I thus recommend a feature change on the splash screen so that the “Close” button be renamed “Close this page and activate scaler 2” or words to that effect.

Hi, I had a similar issue with FL Studio. I tried to upgrade by overwriting the existing version. I tried a couple of times. Black screen only. Finally, I completely uninstalled, restarted my PC, and then installed fresh. Working nicely.