How to make the built-in performance phrases sound moderate or quiet rather than angry?

I did some topic searches on this forum, but it didn’t pick up any relevant posts. So, my question as a newbie is about the performance phrases etc.

I can’t figure out how to dial down the hardness (loudness) of the velocity property that’s sent to a plugin instrument. I’m not seeking anything that’s that’s good enough for a final production, just something that helps me to develop a composition.

I want to have at least an element control over the subtlety of the automated performance, but whatever tweak I try, the result still sounds like the automated player is slamming the keys like someone in who is very, very angry. I’ve tried setting the velocity midi cc of Scaler’s controller midi track to almost zero, and the result is still very loud and very harsh. Am I missing something?

Since you didn’t list your DAW or OS so I can’t be specific but almost all modern DAWs have MIDI modifiers in them for just such a use. I use Cubase 11 on a Mac mostly these days so in the track receiving the Scaler info I use a MIDI compressor that lets me dial down the maximum velocity. Live has this as well.
There is nothing directly in Scaler for this yet on a global level. You can go into each chord and edit velocity per note but that not practical. Basically you want to limit the high velocity down so it’s not above 90 or so.
There is an external plugin that is free that I mention here… MIDI filter modifier - MIDI Polysher

Thanks for the info, I’ll check out that Midi Filter Modifier plug-in. I was just curious about that aspect of of Scaler’s super impressive feature set. I’m using Studio One 5, by the way, which I’m very happy with. (I sometimes use Cubase Elements 11 as an alternative environment that might spark serendipitous inspiration).

The developers of this software deserve all the praise they get, it really is beyond excellent. The doors it opens in terms of discovering musical ideas that would never otherwise have occurred to me are wonderfully satisfying. It’s already expanded my musical horizons immensely.

I can probably work around the velocity intensity thing – I’m guessing by recording the midi output of Scaler and manually editing the velocity levels, which is only mildly time consuming.

I would recommend limiting the velocity globally rather then edit for 2 reasons - editing by hand is time consuming and you don’t hear it at the volume you want as you are composing. If you turn on humanize velocity in Scaler it helps but until the Devs add a global velocity out leveler 3rd party modifiers work. I have Studio One. As well so I’ll take a look. There should be a simple function in there. I won’t be home for awhile though.


I’m not sure I understand your problem, but it sounds like your controller may be sending MIDI at a fixed value of 127. The Scaler Instruments respond reasonably well to MIDI velocity. I don’t think any of the preset performances have fixed velocity values, but some may. If one sounds odd, try others, if you have the same problem with them all, then I’d check your controller’s MIDI output settings.

Editing MIDI velocity is one of the most common and useful MIDI editing tools in all DAWs.

Good luck getting this sorted out. Pull down the fader in your DAW to lower the level, adjust MIDI velocity of notes to less than 127.

Studio One has a MIDI filter but it only filters notes out above or below a certain velocity setting not transform them. Not that useful. MIDI Polysher might be the best for now. In Studio One you have Scaler feed the input of MIDIPolysher and MIDIPolysher out to Instrument. You can use MIDIPolysher for many things including note range, transpose, etc. Set the Velocity transform to Limit and set the max value you want.

Thanks for your help. My controller is definitely sending MIDI at variable values (rather than fixed at 127); these values are also editable in Studio One’s piano roll. I’m thinking the issue might be DAW dependent. The good news is that I think I’ve found an quick work-around (but it might not be as good as the one suggested by Jamieh that uses the Polysher vst)…

In Studio One, for each instrument track, in the Inspector properties there is a setting called ‘Velocity’ that allows you to increase or decrease the incoming Midi values by a chosen percentage. For incoming Midi from Scaler, setting that option to about minus 20% (-20%) brings Scaler’s Midi data within the range that Studio One can work with.

1 Like

Very useful information, Jamieh, and thanks for taking the trouble to post an annotated screengrab. I did download Polysher but it came with no instructions at all, so I was puzzled about how to use it. Your diagram is very helpful.

This looks like the better, simplest solution. I missed that the first time around since I haven’t used Studio One in a while. I’m preferring Cubase 11 these days.

Yeah that works but also make sure your third party VST patch (particularly if its a synth) is responding to velocity. Obviously easy way to check is (without scaler) press a key softly and press a key hard. Should be a difference in volume.

The vst plug-ins I’ve tried (TruePianos and an Arturia piano patch) do respond to velocity data correctly.

My use case here is that I’m aiming for the Basic 3 phrase (from the Common Phrases set) to play the piano vst instrument very delicately (to make it sound quiet and thoughtful rather than brash and bright). So perhaps my initial post should have made that clear.

Really, this is just me learning how to use Scaler. I’ve now learnt quite a bit about how to control the velocity levels. My piano vst is now being played sufficiently delicately by Scaler, so my problem is solved.

Are you using the velocity scaling in Studio One then? Cubase has its own version and it’s what I use now.

Yes, I’m using the velocity scaling in Studio One. From my experiments, it is also worth paying attention to how hard or soft you record your key-locked chord switching performance from Scaler, especially if you are aiming for a result that sounds like it’s being played with a light (soft) touch rather than a heavy touch.

Absolutely. Scaler responds to velocity pretty well. It’s only when I have Scaler locked to DAW triggering itself that it gets too loud and I ramp velocity down.
BTW I highly recommend the Hammer + Wave Pianos for Scaler. Truly a grand set. Hammer + Waves

yep indeed thats what I do, record the trigger notes and adjust velocity, don’t forget humanise for some nice feel too

1 Like

Thanks, everyone for your tips, I’m so glad I persevered after my initial faltering steps with the software.

As someone who has a basic knowledge of chords for guitar and keyboard, I’m one of those people who has, until now, preferred to trust my untrained musical ears when writing tunes rather than delve into the theory, never bothering myself with such concepts as keys or scales. So finding and learning how to use Scaler 2 has widened my musical horizons massively.

Here’s the short ‘cinematic’ piece that prompted my question about velocity levels. I wrote it using Scaler 2 as a tool to help me discover a chord sequence for subsequent inspiration. Also, the ‘Basic 3’ performance phrase from Scaler 2 helped a lot because I’m not a proficient keyboard player.

Soundcloud: Lost And Found