How to use trigger notes for scaler and Kontakt simultaneously?

Hi!

In the screenshot I’m using short trigger notes to get scaler to change patterns. The Kontakt instrument (Electric Mint) that scaler is controlling, uses the same trigger notes (C1, D1, E1 etc) to change phrases, but these notes are triggering scaler only. How can I get around this and program trigger notes that Electric Mint will respond to?

Thanks.

are you trying to get Scaler to keyswitch the pattern in Mint? or you have MIDI from Scaler which has the keyswitches plus the notes?

first thing - are the notes making their way to Mint? if not check your Kontakt settings for the MIDI input and Audio outputs, then make sure the track MIDI controls are set to that MIDI channel and the audio track is set to the Kontakt output.

one thing to check if the keyswitches are an issue - is the octave setting on the MIDI control for the track set correctly. then presuming the keyswitches are working, then the next thing to check - are the notes in the MIDI in range for an electric guitar?

if this is from Scaler - you might need to raise the octave for the notes (via Edit). given (typically) the lowest note on the guitar is an E2 with standard tuning. although you should hear some of the notes.

You can change the trigger notes of Scaler under Preferences and Gear Icon on the upper right. You can move them down by Octave. and various things.
Screen Shot 2024-07-04 at 2.19.31 PM

1 Like

Hello and thank you both for your replies.

I’m kind of getting my head around this, but I’m wondering if there’s a better way to manage the trigger notes for scaler and a Kontakt Instrument?

In my piano roll screenshot I’ve dropped the bind notes in the scaler playback settings an octave lower and transposed all the MIDI notes in my region down an octave also. Scaler is playing back the pads in the screenshot as expected and triggering the selected phrase in Electric Mint. However, if I want to change phrases in Electric Mint, the notes triggering scaler are in the way. I still can’t trigger the different phrases in Electric Mint using the notes C1-D#1. Is the easiest thing to drop scalers bind notes down by 2 or 3 octaves to get them out of the way of C1-D#1, so those notes can be used to trigger the different phrases in Electric Mint?

Thanks.



that or raise the notes well above what you’re playing. but you definitely want the phrase notes to be set so they can alter the phrases in Mint. in my DAW - CW - the MIDI track is set to it’s default, so i often have to raise the phrase notes 1 octave up so the performance notes are were i want them. othertimes i have to raise it all - in which case i can use the MIDI base key value to “transpose”. you might have something similar in your DAW as well.

Thank you fossile.

I wonder if kontakt allows us to transpose its trigger notes (C1-D#1) to a different octave? That would be handier, I think. I’ll check the manual.

I couldn’t figure out how to transpose the key switches in Kontakt (maybe it’s not possible?), but transposing Scaler’s trigger notes and the notes in my region is working nicely.

Thank you both for your help :slightly_smiling_face:

It depends on if the Dev set it up in Kontakt. The Dev needs to do it when they develop the instrument. Some don’t.

Ah, I see. Thanks jamieh. You’d think they’d standardise that kind of thing.

Anyway, the suggestions from you and fossile are working nicely.

maybe you’ve already tried this, but in Kontakt, you can shift up and down the keyboard using that +/- to the left of the keyboard. So while the coloured labelling remains the same, it applies that mapping to other octaves on the controller… assuming of course you have more than 41 keys