Joining Patterns of Different Lengths

I don’t know if this has been asked, but I have a simple(?) question…I have two patterns, one is 5 bars, the other is 7 bars. I bind the patterns to one note each (C and D) In pad mode, but when I switch to pattern two, instead of starting with the first chord, it starts at chord number 6 continues to chord number 7 and then starts at the first chord of the pattern. I would obviously like pattern two to start with the first chord!
I hope this is clear. Can anyone tell me what I’m doing wrong? Thanks.

Hey @Yanidee
I’ve tried to replicate what you are doing and I’m a little lost…but I’m also a little slow. Others might see the issue, but in the mean time, a couple questions and a request:

  1. What exactly are you doing to “bind the patterns to one note each”? Patterns are sets of chords and as far as understand, you bind a note to a chord but not to a pattern containing more than 1 chord.
  2. When you say you “switch to pattern 2” what exactly are you doing?
  3. Are you wanting Scaler play the patterns automatically when you hit a note or are you playing each chord w/in a pattern by playing a bound key?

Maybe you can send a screen shot of your Pad view.

I have two patterns…I go to the pads window…I press the play button.

Once pattern one plays, I want it to go to pattern 2 automatically, but it doesn’t, so I press the lower d note on the scaler keyboard, and it does go to pattern 2, while still playing…but…it starts playing the 6th chord of pattern 2 (pattern 1 only has 5 chords) and once it plays to the end of the bar with the 7th chord of pattern 2, then it starts at chord number 1 (of pattern 2). I want it to play the 5 chords of pattern 1, then continue playing the 7 chords of pattern 2.

Basically, all I want to do is chain 2 patterns…except one has five chords, and the other has 7…

I’ve realized, i can trigger the chords of pattern 1 with the standard binding notes, then by pressing the lower d note, start triggering the chords of pattern 2,but want it to do it automatically. I hope this makes it clearer!

Ok…that is as far as I got so now I see what you are trying to do.
A couple options:

  1. To play patterns in sequence regardless of their individual length, just lasso the pattern buttons (left click and drag or control click and they will turn blue ) (A) and then hit play. Now they should play in sequence
  2. You can also select a series of chords across multiple patterns using * Lasso or ctrl left click* and they will take on a yellow border) (B) now right click and select preview selected chords. No way to use the play head (and DAW synch) on this, but you can get a good midi capture or live capture

Note - you won’t be able to ctrl click to select multiple chords if multiple patterns are selected to deselect, just right click on a pattern button.

Hope that helps

Thanks for taking the time to help. Well, it works for playback / midi record, but I’m surprised you can’t just ,say, play pattern 1 twice, go to pattern two, and back to pattern 1, for example. I hope they implement this down the road!

1 Like

No worries. Maybe there is some trick I’m not aware of…or something is staring me right in the face and I’m not seeing it. But either way I agree that triggering patterns directly would be a nice addition. I play “live” as in dynamically while Scaler is playing and anything that lets me trigger changes is welcome. I can imagine a new grouping layer called parts that lets you combine the patterns in ways that you described. Regardless…lots of great stuff in here to play with.


Actually I just found it…You don’t have to select all the chords, all you have to do is lasso the pattern names on the left, at the beginning of each row and press play! The names (Pattern 1, Pattern 2 etc) will turn from white to blue, and It will cycle through.

That is literally what TMacD said the line labeled number 1.

1 Like

He wrote that he didn’t seem to understand what I was asking, so I was more pre-occupied with explaining it to him…I see now,that he answered my question…but continued, with “ctrl-left click”, etc…so I Iost him! I did thank him for his reply…but it went on…so I persevered until I found it as well…best way to learn frankly.
Nobody else replied…people just notice when you f**k up (ha-ha)…I un-ticked the solution check box, so I guess all is well now…

I was just about to reply when I saw that it had been answered. Maybe I should have just tried to clarify what was there. I’m not sure why he mentioned control-left, etc. when it is just a lasso around the patterns.
In any event, that should open a whole world of exploring.
Don’t forget to check out the playback settings for each pad on the grid. The pads can play more then just the global pattern. each can have their own.

Thanks…there really is a lot to this program, and it’s worth it to take the time to learn it’s capabilities (like any software)…Cheers to u…

Glad all worked out.

FWIW, I added the 2nd option above because it is an easy way to audition sequences of chords before adding them to a pattern with a right click.

When you do check out the Playback settings as @jamieh mentions, be aware that the Playback Timings (A) are not reset when you do a Clear State (B) (accessible by right clicking on the Scaler name)

1 Like

Good to know about the clear state. I rarely do that it could trip you up.

Yeah…a little bug that really bit me a while back. Spent hours trying to figure out why a beat was just a tiny bit off on one machine but not on another. To make matters worse, I was on a laptop with a small screen so the already small fonts in that part of the UI hid the issue. Never in a million years would I suspect that clear state does not really clear the state. :slight_smile: It sure seems like an easy bug to fix but that is above my pay grade.

Never noticed a Clear states menu existed in the Scaler name
It seems to me you that can clear right-clicking on the pattern button itself and in this case the clearing works

You are right, this is a mistake it will be fixed. When replacing a chord by another one or even by a rest we want to maintain the timing information. The code to clear the state was wrongly applying the same logic instead of clearing everything. :face_with_monocle: :thinking:

1 Like