Keeping Pad view performance settings active when playing selected chords across patterns

If you use the pad view to build patterns with chord specific performance settings, you might have found that selecting chords across different patterns and using the right mouse button to “preview selected chords” seemed to disregard chord specific performance settings.

If you did, the fix is easy. Just be sure you don’t have more than one pattern selected as active (bound).

A visual:

The pad view below has 4 patterns each with a different performance setting. The 1st named Global is what ever Scaler is set to, the next one BP 1 1/2 is Basic Pattern 1 at half speed, etc, etc. The current active pattern is in blue BP 1 X2 If multiple patterns were active (bound) they would all be blue.

I use this setup to play around with different combinations and when I find something I like I select the chords of interest in the order of interest (ctrl click) and then right click to select Preview Selected Chords" Then if it sounds good I either capture the MIDI and send it to my DAW or I push the selected chords to a new pattern so I can play it on my keyboard.

However, when I recently started adding performance settings and not just timing changes, it seemed that Scaler was only using the Global performance and not the individual chord settings. Once I made sure only one Pattern was bound (active) the performance info was read as expected.