Key Locked “Chord Notes” Playing Chord Changes on Beat 2 instead of Beat 1 (Error)

Hi there,

Every time I turn on Key-Lock and set it to “Chord Notes”, then set Chord Mute to Muted, the proper chord changes execute on beat 2 instead of beat 1 (not on the downbeat). When doing this, Scaler holds the previous chord quality and drags it into the next downbeat instead of switching chords on each downbeat like it’s supposed to (everything else, including the performance mode is synced properly to my DAW but not the Chord Notes).

I am on Ableton 11.0 and Scaler 2.4.0

Is everyone else experiencing this issue and is there a solution? This surely isn’t how the “Chord Notes” feature is supposed to work (playing changes on beat 2 of a chord change instead of beat one). It would be awesome to have this Key-Lock / Chord Notes / Chord Mute feature working properly. Any advice would be appreciated!

Many thanks!


Welcome @Lockmatik That’s not the expected behaviour and hard to tell what’s going wrong without seeing what you are doing, first thing to try is slightly shorten the trigger note if you are using them so they are not legato. Next thing is look in the Play Quantize menu and ensure that is not having an effect on chord trigger (waiting for next beats etc).

Hello Davide, thank you for your response. I am experiencing this issue while playing notes on my MIDI keyboard live (while using Keys-Lock + Chord Notes + the Chord Mute Setting - and while synced to my DAW). The same issue is present when using quantized staccato MIDI notes in an Ableton Midi Clip to trigger the Key-Locked “Chord Notes” in Scaler 2. And thank you for the suggestion about changing the quantization settings but I have tried both settings in the Play Quantize menu (Play Quantized To: Chord Duration & Next Beat) and that does not solve the issue.

Here are 2 videos to demonstrate the problem. This first clip is simply using DAW Sync with Playback Loop enabled to play some chords. You can hear that Scaler 2 is synced properly, and that the playback is correctly changing the chord qualities on the downbeat with Keys-Lock + Chord Notes turned off: Scaler 2 - Correctly Synced with DAW (Without Keys-Lock/Chord Notes) - YouTube

This second clip is using Keys-Lock + Chord Notes + the Chord Mute Setting which is being triggered by quantized MIDI notes in Ableton. This video demonstrates chord changes incorrectly executing on beat 2 instead of beat 1. The very first bar plays the correct chord quality on the downbeat but you will hear chord changes executing on beat 2 starting on the second bar:

I have been through a lot of troubleshooting but still can’t seem to resolve this. Maybe I am overlooking something since I am relatively new to Scaler, but I’ve been through so much trial and error troubleshooting with this issue that I discovered a very strange circumstance that somehow bypasses the issue - but it is not a practical workaround. If I nudge the drum beat over so the kick transients are very late, and not on beat, the Keys-Lock + Chord Notes will play the chord changes correctly on the downbeat. ¯_(ツ)_/¯ Am I crazy or is scaler reacting to the audio (drum beat) in Ableton? The beat has to be late (only half a second or so late) and nudged to a certain position, and the Keys-Lock + Chord Notes feature works properly. Again, that really isn’t a usable workaround for what I’m trying to do.

The same issue is present in Ableton 10. I’m wondering if trying an older version of Scaler help but I haven’t been able to find an older version to download. I am new to Scaler, and version 2.4.0 is the only version I’ve tested this on. I will be super excited to use this feature if someone can help me get this working properly. I’m enjoying the other features, but the Keys-Lock + Chord Notes + the Chord Mute Setting is my favorite feature of scaler. It’s nice that you can play clusters of white keys live over changes and play different inversions moving up and down on the keyboard while it’s synced to Ableton and looping the chord progression.

Please let me know if you have any suggestions. Is it possible to contact the developers or some kind of official support representative about this issue or is this the best place to discuss issues like this?

Many thanks,


Hey Josh

Hate to explore the obvious, but here are a couple things to also look at.

  • Clear State does not reset timing data, so check your Playback Timings in Section C
  • Check Preferences for Chord Duration setting

Hey TMacD,

Thank you for your input. Here is a screenshot of my Scaler settings in that section. Please let me know if you see anything that appears to be problematic, or if you have any other suggestions to resolve the issue. I would be happy to share other screenshots (it will only allow one screenshot at a time here).


No problem…figured it was a long shot but sometimes its worth making sure the plug is in the wall. :slight_smile:

The Playback Timing disconnect with the Clear State function caused me much frustration until I figured it out. The only other simple issue I can think of might be your default Chord Duration setting but Settings/Playback/Chord Duration but I suspect you’ve tried that.

People here love a good puzzle so one thing that might help people test is to create a really, really simple and obvious example that demonstrates the issue. One they can replicate with little hoop jumping.

This crew is sharp and eager to help. I bet they get it sorted.

Good luck

Hey @Lockmatik

could you please share a screenshot of the Settings in the side menu.
It would help to see the performance options and playback mode that could be active.

Also, what are your audio settings in Live? (what samplerate are you using?)

This could be a MIDI routing issue. Check if there is any device or track that could be sending notes to Scaler.


Hi Ed,

Thank you for helping me look into this. My sample rate is set to 48000 in Ableton. Here is a screenshot with more of my settings. Please let me know if I can provide more relevant info as I am happy to share any info that could be helpful.

When I delete all tracks and only have 1 MIDI track with Scaler loaded in Ableton, the issue still persists - so It might not be a MIDI routing issue. I have also tried loading Scaler 2 in Ableton 10 and I am experiencing the same issue. I have not tried an older version of Scaler and am not sure where to download old versions of the plugin, although I haven’t searched too deep for a download.

Please let me know if you see any problematic settings!


Hi @Lockmatik

It looks like you have the “Play quantize to next beat” enabled.

It will delay the trigger to the next beat. Try to move your trigger note slightly before the beat or disable this option in the side menu.

This should solve your issue.

Hi Ed,

Thank you for the suggestions. I was hoping that changing the “play quantize to” settings would solve the issue as well but unfortunately it does not. I see two options for that setting: “Next Beat” and “Chord Duration” - both of which I have tried. If there is a way to completely disable the “play quantize to” option that I am overlooking please let me know, but I only see those two options.

Also, I tried moving the Ableton MIDI notes that are triggering the chords slightly before the beat but Scaler is still changing the qualities of the chords on beat 2. Please let me know if you have any other ideas!


I installed scaler on a different computer and different operating system (Windows with Ableton 10), turned on “Keys-Lock”, set Keys-Lock to Chord Notes with the muted option selected in the settings - and the same issue persists with chord changes are executing on beat 2 instead of beat 1. This makes me think it is some kind of bug, and not an issue with my settings. I can’t imagine that this is expected/intentional behavior for the muted chord notes feature as Davide pointed out. If it is a bug, I’m surprised other users have not pointed it out - but maybe the muted chord notes is not a commonly used feature. However, I think it’s one of the most unique features scaler has to offer and I am hoping someone can get it working correctly.

Can anyone here test this scenario out on their own system and confirm that the chord qualities are changing correctly on the 1st beat of each measure? I uploaded a very simple Ableton project to Google Drive that demonstrates the issue. Please make sure your DAW is synced, “Keys-Lock” is on and set to “Chord Notes”, and that Chord Mute is set to Muted in the side menu settings. I placed Ableton markers on the timeline to make it clear where the wrong chord qualities are playing. Please download the Ableton (.als) file here: Scaler - Muted Chord Notes Example 1.als - Google Drive

I am hopeful that someone is able to resolve the issue. Thank you again for your time and assistance with this.


I tried this out on my Mac with Ableton 11. It behaves as you state but I’ve never used Scaler this way and I am having a hard time figuring out why I would want to. What exactly does this do?
I see that the MIDI is all one chord and you want to change that based on Scalers chords but why?
One other thing, if you turn on Performance mode - Instant crash on Play.

Thanks for testing that and confirming.

What I have in mind is mainly for live looping/performance purposes. The only reason I inserted the midi clip into this project was to make a clear example that it isn’t working properly, I am mostly using it with a MIDI keyboard. When working properly, it allows you to easily comp different chord changes in one hand while having control of voicings (including variations of chord voicings which can be key triggered). And unlike cthulhu/other chord plug-ins, it let’s you easily invert the voicings by smashing keys - which is much more fun than simply pressing one key to trigger a chord. And it’s fun to easily invert/smash keys while using your other hand for something like playing a synth lead or changing filter/other fx parameters in ableton. My keyboard skills are not at the level I would like them to be so I’m finding it useful for playing complex jazz chord voicings/progressions with ease while coming up with grooves in ableton. I’m liking the ability to quickly voice the chords myself instead of using notes that are restricted to built in scales (the other keys-lock options). Having control over variations on the playback timings compliments everything described above well too. It would be cool to have a wider range of inversions but even with two octaves it’s been sparking a lot of interesting musical ideas for me. I would like to see the devs expand on this feature and am hoping they have a fix for changing the qualities.

Hi @Lockmatik

The team are looking into this. I can confirm that it is not behaving as expected and we will be looking to resolve this.
On another note, I like the creativity with your workflow and find it rather inspiring!


Thank you, @james! I really appreciate that and hope to see a fix in the near future.


Updated to 2.4.1 but it doesn’t appear that the issue has been resolved yet. Thank you again for looking into this and I’m hopeful to see a fix in the near future.