Key Switches to follow Midi track and Play

I want to be able to do all the creative side of my songs in Scaler.

First, by creating the basic patterns for each part ie, Intro, Verse, Chorus etc. See the image below:

For each part, you’ll see that the Keyswitches correspond to the light greens Keys, C1, D1, E1 etc.

I created a midi track to select the key switches—the notes on that midi track correspond to the structure of my song.

When played, the Keyswitch Keys are selected corresponding to the midi notes. Which you’d expect.

However, there is no output.

I’ve tried changing instruments, but no luck. I’ve even tried Scaler as an Instument and using Live Sync… nothing!

I’ve seen Davide create a quick Keyswitch track, but not quite been able to work out what he does.

I can select all the patterns/parts, but this picks all key switches, and although it plays through them all, the Keyswitch midi track has no control.

I’ve added a video to help, hopefully.

If you know how to solve this, please help and save me from going completely insane with frustration.

Or… is it not possible with Scaler?

Mac OS 12.6 Monterey MacBook Pro M1
Logic Pro 10.7.4

1 Like

Sorry @Alfie but your video doesn’t play. Can you please check the privacy settings on the video?

Could you also export the Scaler state (click on the Scaler logog and export the state) and upload it here, please, then maybe a user with Logic may be able to help.

HI @ed66

Thanks for reply. I’m not sure why video not working for you. I have asked a few others to try and seems to be working. Can you please check.

The Scaler state is just a set of random chords put in different patterns/parts to check working, so really simple for anyone to quickly set up. It would be interested to hear from anyone using LPX, but I would also like to hear from any other DAW users who could also try this out. If it works for one, maybe there is a Logic issue.

I’ve just gone back to look at video clip and replaced link, but it looks the same. Fingers Crossed it works. Please let me know.

Mac OS 12.6 Monterey MacBook Pro M1
Logic Pro 10.7.4

Hi @Alfie

This is a screenshot of my browser when I open you link to the video.

When you export the Scaler state the xml file includes a host of information about Scaler. If you export it and upload it to this thread then other users can import it into their Scalers and try to replicate the problem. It will make it much easier to provide support.

I notice in your screenshot that you are using the midi fx version of Scaler (I am a Windows user so I don’t use this version). I am not sure if this will produce any audio output but have you tried routing the output to a synth?

Just looked and the vid plays for me. Hmm?

Hey @Alfie, I’m looking in to Key switches later today and will see if I can replicate.


And now the vid is playing, maybe I was too quick in picking up the thread, ho hum.

Hi @TMacD

I’m happy to bounce ideas and try whatever, so just let me know.

Hopefully the information was ok, but if I can clarify anything, please fire away.


Mac OS 12.6 Monterey MacBook Pro M1
Logic Pro 10.7.4

Here is how I just set it up and so far it is working as expected:

Maybe it is a monitoring or DAW synch situation. When I watch your video, it looks like your DAW synch in enabled but I don’t see any chord triggering. I can’t get that to occur on my setup (DAW Synch on and No Chord Triggering)

Do the chords play if there is no KS track or if it is not active?

FWIW, here is my test rig:

Windows / Studio One 5.5
Track 1 - Scaler with 4 4 chord patterns in pad mode with only one pattern active
Track 2 - Duplicate of track 1 with a midi part corresponding KS notes

To test the KS, I hit play in the DAW (no DAW synch enabled) and Scaler triggers key switches as expected
To play, I enable DAW synch, hit play in my DAW and Scaler plays the chords with patterns changing as expected.

Let me know what you find.

This is the same test I did on Mac and Ableton Live and it works exactly like this. No problems.

The only way I can get Scaler to not play it’s chords when DAW synch is enabled is if I disable that instance of Scaler. Then however, it does not register the key switch (as expected)

Also, I see he is running Scaler Control with the MIDI FX setting and i have no idea what that does differently than the regular Scaler.


As I thought the midi fx mode of Scaler does not produce any audio output. The manual states

A MIDI effect does not have the ability to output sound so you won’t be able to use Scaler
internal sounds and need to load another instrument on the same track.

So using the midi fx version of Scaler as @Alfie appears to have in his video, with no output routed to a synth, will not produce any sound. As I asked earlier

which should produce a sound.

duh…missed that. RTWFT! :slight_smile:

Hi All, and thanks for taking the time to look at this.

I’ve been trying different ideas with varying results, but I think I’ve got it.

Check out the video: You will see that the midi track to trigger the Key Switches works as it should, and the chords for each pattern play.

The Midi track goes from Pattern 1 to Pattern 3 and then Pattern 2; repeat.

Midi to control KS and play patterns works… But!

This morning I was trying everything and anything I could think of and then I just clicked this:

It played as I had hoped. It went from Pattern 1, 3, and then back to 2.

So, to ensure this was the answer, I had to replicate what I had done from scratch but, and it’s a big but, it’s unstable!

I started each time a new and used the exact settings. Out of 14 times of trying, it worked 6 times. Sometimes it selected the correct KS but didn’t play the chords. Other times it didn’t do anything. The only answer was to close the project and start again.

I think there could be a Logic problem with Scaler. I say this because @TmacD seems to have got this working ok in Studio On 5.5. I would love to know if anyone else can get this to work with Logic using the same method I described below.

Set up: as you can see, it is very simple; 1 midi track, corresponding to the keys switches and Scaler as the instrument. In Scaler Instrument, I created patterns 1, 2 and 3. The DAW synced and Loop on.

I would love to hear your comments, and ideas, and maybe someone from the creative team may have the answer?

Mac OS 12.6 Monterey MacBook Pro M1
Logic Pro 10.7.4

Here is another example of me using a midi track to activate the Key Switches in Scaler.

You’ll see the appropriate Key Switches being triggered by the Midi track to match each part of the song stucture.

Using Midi Track to control patterns and chord playing
First, I create a midi region and add Scaler as the Instrument.

I have a basic song structure marked out using Markers. This gives me a structure to work with, but it is just a guide.

In Scaler, I build the different Patterns/Parts in Section C Main Window. (1) to match the song parts I’ll be using, such as Intro, Verse etc.

Then I opened the Pad Window (4) to see all the parts and the relevant Key Switches, shown in green on the Scaler Keyboard.

Back in the DAW, I write midi notes to correspond to the Key Switches that activate the individual parts ( intro, verse, chorus etc.) and play the chords from that section.

I then ensure DAW Sync is activated and click on the Loop icon to the left of the play button in the Scaler Pad Window.

I can now play the whole basic structure of the song in Scaler and make changes without leaving it.

You can make all the changes and try out all the options for any parts while remaining in Scaler. It is the closest you can get to using Scaler as a stand-alone.

From here, usng such things as the new Live Sync could help build the song.

Using just one Instrument, rather than multi-tracks and multi-instruments, is excellent for saving CPU resources. Every track and every Instrument used uses valuable resources.

It keeps the DAW clean and free of clutter.

I’m sorry the video has no sound; I couldn’t capture the system audio. However, although not a great song, it played great.

Mac OS 12.6 Monterey MacBook Pro M1
Logic Pro 10.7.4

1 Like