Logic not reading correct Scaler tempo

Hi, I am new to Scaler and would really appreciate if someone can help me with this.
As I can see and hear, my Scaler tempo is playing 60bpm, but when I drag to Logic, if i import tempo or not, it still reads it as being played much faster (120, 130…).

I double checked this using a metronome, so let’s say all my chords are set to 4 beats in Scaler, that would be 1 chord per bar 60 bpm.

But when in Logic that same speed of chords is read as 1 chord per 2 bars (so double speed).

I like the speed of chords being played and don’t want to change that, but I want to add for example the logic drummer and make it play in the same, correct tempo.

How do I solve this please?

Welcome to the forum @theballadgirl There could be many reasons this happens but to eliminate Scaler being responsible could you please check something - are you using Scaler 2.8 and if so what sample rate do you have Logic Pro set to? Try setting Logic to 44.1kHz and try again.
FInally use the MIDI CAPTURE in Scaler and then drag that in, do you get the same behaviour?
If Scaler is set to 4 beats and you have 4/4 set as your time signature in Logic then dragging the chord from Scaler to Logic should result in chords being 4 beats (1 Bar ) each in duration.

1 Like

Hi Davide, thank you so much for your quick reply and creating this amazing product.
It was a beginners mistake, I forgot that logic has the tempo automatically set to 120, so I had to first set the correct tempo there and make the chords respond to that… Now it’s all working well.
Thanks again, I am really enjoying Scaler.