MIDI recording outputs empty 86k bars files

Been using Scaler today as VST in Ableton has been fine until it started outputting empty midi files on record midi + drag.

It works intermittently if I play a few bars and drag a file, but anything like 16 bars it creates this empty file with around 86,000 bars.

What I tried already.
Shutting down, reopening the als file.
Didn’t work.
Shut down Live again and set up a new file with Scaler and Kontakt for a drumkit sound.

Went online, found there was an upgrade. Upgraded to 2.09. Set up a new als as before. Confirmed it is 2.09.

Setup
Live 10.1.17 (last update was 27 July)
Osx 10.15.4
Scaler 2.09
Midi keyboard is Novation launchkey mini - sometimes it loses connection with Live but hasn’t been doing that today.

Recording MIDI in key bind mode to play chords and drag the chords not the trigger notes into another instrument.

Made a loom video of the issue.

You won’t hear music as it’s thru phones but you can see the issue in the video.

Any advice welcome thanks
Gary

UPDATE> I just found this thread (it won’t let me put 3 links in this post)

It seems the behaviour is caused when recording in Session Mode using a drum loop that is shorter than the number of bars I’m playing in Scaler. By extending the drum in Session mode to 64 bars I am able to record anything up to that and drag it with the file being as it should be.

Weird I never noticed that before - I’ve only used Scaler in Session view as that’s where I start writing.
Easy work around at least.

FURTHER UPDATE:
OK so making a super long drum loop worked a couple of times but after that it’s still outputting massive empty MIDI files. Very odd.
(I did get one 12 bar section to output correctly after I thought the longer loop solved the issue)
Here is another loom.


One more update - Scaler is randomly outputting the correct chords MIDI file about one in every 3 or 4 attempts, otherwise it’s just massive empty files.

After a restart of laptop it was working fine for a little while now I’m getting what someone else on here had - 800 or so bars with the midi recording right at the end and out of sync.

In a fresh session that was working earlier I’m now exclusively having the 800 bars with the MIDI stuck right at the end. Better than no MIDI and 86k + bars but frustrating nevertheless.

Hi @Pericles

thanks for reporting with all the additional info. We will have a look at this.

1 Like

Hi There, any update on this? I was using Scaler again today, approx 70pc of the time its doing the 80k plus and out of sync Midi files, 30pc behaving properly. I tried to work out what - if anything - was causing it to work/not work but can’t see any common ground as to what makes it happen one way or the other,
thanks

I’ve found a common element that seems to cause this behaviour. In most Live 10 sessions I used Kontakt Player with Realidrums just for some basic beat whilst I improvise with chords in Scaler. I’ve realised that if I’m using just a percussion loop from Ableton clips packs the Scaler output works as it should.
I tested with RealiDrums and the bad stuff happened. I deleted the Kontakt Player instance and reloaded but this time with Shimmer Shake Strike and the Scaler output works as normal.

I have noticed in the past that RealiDrums has some annoying thing where it can double and triple trigger a pattern and I’ve never worked out how or why. Normally I use it to grab a groove and drag the midi clips to a Live track and trigger the plugin from the midi loop.

I will keep playing with Scaler and dragging and dropping but that behaviour is repeatable and does seem to be only when using RealiDrums inside Kontakt player.

Hi @Pericles

We are still investigating, we have fixed a calculation error but still testing it at the moment.
The super large clips seems to happen under specific conditions, hard to reproduce so this will surely help.

Thanks,
Ed

1 Like

Hi,
I am having the issue using Scaler 2 version 2.0.9 in Ableton Live 10.1.15 where 800 to 3000 bar length MIDI files were created when doing MIDI Capture with DAW Sync on.
For me it was happening when I would stop Ableton before stopping the MIDI Capture. If I stop MIDI Capture first then stop Ableton, the MIDI file is the right length and in sync. Hope this helps.

Den

1 Like

Yes, this issue is reproducible, I think it was already acknowledged in another thread. I can reliably reproduce this behavior too, when stopping DAW transport before MIDI Capture in Scaler, it puts out thousands of empty bars in the piano roll.

1 Like

Thanks Ed, Den and Bernd.

Den I also wondered if it was the stop transport BEFORE stopping capture midi in Scaler. I think you may be right. I would have been doing that as a matter of course - until it was causing issues and I was being ultra cautious to capture clips. I will see if I can reproduce this without RealiDrums plugin being involved.

Having tested again and specifically tried recording MIDI with RealiDrums loop playing inside a session clip, hitting STOP in Scaler and dragging and dropping the clip BEFORE stopping the transport bar creates a Midi section as it should be, exactly the number of bars played and in sync.
Testing doing exactly the same thing but stopping transport BEFORE stopping Scaler record and drag and drop causes the 89k bars issue. Hope this helps.