More on the Melody Question with a few screens for clarity

I checked this further and created a few screens which I hope help.

I’m not sure there “is” an answer so my hated workarounds may have to do.

Image 1.
A normal starter Scaler Track with Bound notes to Patterns.

Image 2.
Scaler GUI and Lead “Melody” Track (Vital VST). Scaler is in Keys Lock Mode, Scale Notes Only. Blue Keys with out-of-scale notes silenced. DAW Sync Off.

Image 3.
Piano Roll “Key Editor” showing Scaler Transmitting Notes for chords that have a note corresponding to the Scale, other notes are silent. The shorter notes are the “melody” (random notes for example). Note the long tones from the Scaler track and the short duration notes of the “melody.”

My hated workaround is hand removal of the long tones. Since I’m working with fixed duration notes on the Scaler track (starting point) it’s relatively easy to find and remove the notes. However, I usually change chord durations for more interesting harmonic rhythm so chords don’t always change on the downbeat of each new measure.

My previous post in the other thread had some incorrect statements so I opened this new thread on the topic. I hope these observations are useful and clearer. It’s rather amazing that Scaler does all this. I have additional thoughts about improving this functionality but will put those in a separate post under Feature Request/suggestions.

As always, thanks for any comments or suggestions.


Sorry, I didn’t check your profile.

I do not use Cubase, but I wonder if this is an issue with midi channels and routing? I have tested this on both Ableton Live and Reaper, and found the issue does not occurs in either. The output is simply the notes of the performance or chords if performance is not enabled. I have tested it using both an arpeggio and basic performance 1.

Have you tried lowering the key switches and binding range an octave and then using key ranges on the input to the synthesizer to restrict the irange to the melody keys as a workaround?

No prob on the profile check.

I’m not using the internal performances at all. I’m creating a melody line using Key-Lock, Scale Tones Only with DAW Sync Off. Scaler is targeting the MIDI input of the VST synth “Vital.”

I don’t think Bound Notes or Key Switches can be made lower in pitch but only the display range and input range on the MIDI controller is lower. I’ll have to check that because I’m sure.

Thanks for the idea.

Well, about melodies (or solos as I call them) I often prefer using the DAW-based options, like Scales in Ableton Live (up to a month ago), or Key filter in Bitwig now

With the further improvement made by Bitwig’s Key Filter > Constrain feature that, if I got it correctly, forces out-of-scale notes to fall in the scale, instead of just killing them

On the other hand, the DAW-based options aren’t dynamic like Scaler’s Key-Lock, whose solo notes changes at each chord in the series, so my hope is that a future version of Scaler will be able to join the 2 worlds

Changing the setting in the SETTINGS menu

will change the actual octave for the key switches and bindings.

You can lower them by more than one octave but I would not recommend that as the lowest midi values may already have actions assigned to them.

This looks like an issue with the mapping of your controller to midi in Cubase. I did have a similar issue in Cakewalk, way back whe I used it but it was solved by changing a default setting in the DAW. I suggest you could clarify this on a Cubase forum.

Hope this helps

1 Like


Thanks for the screens and recommendation. I had already lowered the Bound Keys by three octaves which is how I was able to obtain just single notes and not full chords. If I put the Bound Keys back to normal then when Scaler hits that note it (correctly) plays the chord.

The first measures are recorded with the Bound Notes set down three octaves. The second set of measure you see full chords when the Scaler Track hits a note in the Scale. It seems the best I can do for now is to lower the pitches of the Bound Notes and deal with the single notes by hand or by macro.

My primary Controller (for now) is the Akai Advance 49 which transposes up/down by Octave with a simple button push.

My workaround for this does work so I guess I’ll stick with that.

Thanks again for the suggestions and for helping me think this out.


So, I took your suggestions and tried a few things. I’d be surprised if this was Cubase specific, but maybe it is? There may be a way to build a Cubase Macro that would “clean up” the tracks. I’ll have to spend some time with this and perhaps open a thread about it on the Cubase forum.


If I transpose the bound notes down then the Pattern Key Switches don’t work at all. :frowning:

The bound notes do transpose down but still appear on the recorded track (as expected) when Key-Lock is set to Scale Notes Only.

I love that Chords can be muted for Key-Lock Chord Tones and Chord Extensions. Yet, while this is nice and has good applications, it doesn’t lead to strong melodic content, imho. I like melodies or solos to include chromatic passing tones and other non-harmonic tones.

Anyway, thanks for your suggestions. It helped. I tend to try to adapt to what is possible and not fret about what is not. I have a feature request or two based on this exploration and will post those in time.

All the best to you.