Multi Out not working

Using Scaler 2.7 with Ableton Live 11 and Full Kontakt 6.7.1. Enabled Multi Out in the preferences, followed Davide’s intro video but cant get a midi to other channels than No1. Any insight?


Ableton doesn’t play well with multi out plugins. See the thread about instacomposer.

Same here with cubase.

I have :

  • enabled the MIDI multi-out in scaler.
  • created multiple instances of my vst instruments using scaler’s MIDI out as their input, selected MIDI channels 2 to 5 to get the differents voicings and put them in monitor mode

They each receive the full chord and not the different voicings. This feature seems awesome and would be a real game changer for me in cubase

I might be missing some detail about the routing of a specific midi channel in cubase…
Thanks for your help


Hmm. Would Patchwork help here? Can somebody test this?

It didn’t help with instacomposer. I’ll have a play with it now and see what’s what.

I finally managed to do it, all I did was correct but I needed to use the ‘input transformer’ to be able to filter the different midi channels coming from scaler.

A nice upgrade would to be able to have an input per channel for scaler 2 but it works!

I get the same problem. I notice that Davide is using the Scaler Control plugin whereas we have to use the normal Scaler plugin and route the MIDI output to a separate track in Ableton. Perhaps someone from the Scaler team could confirm whether this feature is only intended to work with Scaler Control? Thanks.

I got it to work in Live!

I don’t remember seeing this MPE option before. Is it new in 11.2.6?


Unfortunately this appears to be an option that is only available on MAC, not on Windows! So I’ll continue my port to Reaper where there is no problem.

1 Like

Yes, I think it is in the last version
I mean MPE
Never seen the IAC driver before

Just found this

I have loopMIDI but never found how using it for multiple MIDI out
so I’m stuck on a MIDI track in the middle :grinning:

After further research I think I’ve found the cause of the problem - the internal architecture of Ableton does not properly support multi-channel MIDI. It basically maps all MIDI data to channel 1. Other DAWs are available… :face_with_raised_eyebrow:

To quote from Ableton help page:

What MIDI channels does Live support?
Live can receive MIDI from external sources (eg. MIDI controllers) on all 16 channels. All internal MIDI routing within Live is on MIDI channel 1 only.

Thx for this info concerning Cubase. But it is not working for me. I found the setting You circled in red on the left, but I cannot find the section to choose the output channel You circled on the right. Where is this view “hidden” in Cubase?

Hi folks,

Lots to cover here, but Scaler’s multi-MIDI out functionality will vary given host and plugin format limitations.

As @mking1 points out, Ableton Live isn’t cut out for this kind of thing and setting Scaler as a MIDI track’s MIDI input will combine all the data across all MIDI channels into one channel.

@Bagatell ’s solution is very clever however it still uses a MIDI track with Scaler as the MIDI input (track 2) to funnel the data from Scaler to the IAC driver bus. This will again combine all the data into one channel, defeating the purpose of Scaler’s Multi MIDI out.

MPE may be able to Mimic the behaviour of Scaler’s multi-MIDI out but I’ve had very inconsistant results with this. Let me know if you were able to make this work!

I haven’t conducted much testing with Cubase, but Studio One seems to handle multi MIDI out perfectly, so long as you use the VST version of Scaler. AU plugins don’t support multi-channel MIDI output.

Given the limitation of AU plugins, you’ll need to use the MIDI effect Scaler Control plugin in Logic in front of a multi-timbral plugin like Kontakt to use multi-MIDI out in Logic.

Hope this all makes sense! Let me know if you have any questions.

1 Like

Here’s a thread that deals with the Ableton Live issue and it works. There is a link to download the Live file as well.

@rockbandguy : In cubase you have to select in the ‘input tranformer’ the option track.

Then you have to click a second time and select ‘view page’ (or something like that, sorry my cubase is in French…)

Not very ergonomic indeed…

1 Like

Yes, the dialog should open when I choose it. At least for the first time.
Thank You!

The MPE option splits the channels. Did you set the correct number of channels?

Ableton Live doesn’t internally make the difference between midi channels.
No way.

It does using the method I posted above. MPE is the key.

The solutions offered in this thread involving IAC Driver are MAC solutions. (the IAC driver is a driver for Apple MACs).

I believe that the only known solutions for Windows is to set up a virtual midi bus as per the Ableton Help or to use a plug-in such as Blue Cat’s Connector (see this thread) from Blue Cat Audio.

I have not used these solutions and do not know how easy they are to implement.