My Scaler has stopped exporting chord names with midi

I’m on Win 10, Reaper 6.79, and Scaler 2.7.3

I’d really appreciate some help getting Scaler to export Chord Names with the midi like it used to. I understand it’s the default behavior, and there’s really no way to turn it off.

Here’s a pic showing chords dragged from Scaler. The first is from an old Reaper project, and the chord name was included. The second is from Scaler 2 in a current Reaper project, and the chord name was not included. The third is from Scaler 2, hosted in NanoHost, and the chord name is not included.

I opened these three midi chords in a hex editor and it shows the same. The chord name is part of the midi from Scaler in the old project, but not when Scaler is hosted in a new Reaper project nor when hosted in NanoHost.




This was a nice and very useful feature. Help me get it back?

I would have thought that Scaler running in two separate hosts, and not putting the Chord Name into the midi would be BUG that would catch Dev attention.

A Hex read shows the Chord Name is not part of the midi file whether I’ve run Scaler in Reaper or have run it in NanoHost.

It is just a single setting to set to export midi markers. I’d really like to understand what’s going on.

Maybe @Ed1 could help out here?

This would indeed point to a previous Scaler version filling in the ‘Marker’ section.

I hosted 2.7.3 in Cantabile and my hex dump gives

i.e. no FF06 meta data, which was present in your first dump.

Hi @panda

this last dump shows the filename as being “Scaler-Chords.mid” which indicates that the option to export the chord names was not active at the time of the drag. When enabled the file is called “Scaler-Chords-With-Markers.mid”.

This could explain your issue, the old project is loaded with the setting enabled whereas new sessions are loaded with the export name disabled.

In your first example, the file was called as if exporting with the chord names so we’ll have a look at the code as well but double-check your settings in each project.

Do you get the prompt to import the chord markers at all when dragging MIDI to Reaper?

I see you’re not directing this to me, the OP, but in the examples I provided this Scaler setting was active:
And I did get the prompt you showed.

Hi @mbrowne

sorry, you’re right it was meant for you.

Thanks for letting me know, I just did more testing with the Scaler 2.8 beta in a new project in the latest version of Reaper and I can’t replicate your issue.

In my tests I have a fresh instance of Scaler, simply change the setting for chord markers from OFF to ON and drag a chord from the scales screen (Section B) directly onto a Reaper track.
Reaper prompts me to import the markers and if I accept it shows the name of the chord as it did in the previous version.

Yes, it should take nothing more than that - just set chord markers to ON. As mentioned, I’ve run Scaler in two different hosts and dragged chords from Scaler to my hex reader. Also, I did a fresh portable install of Reaper, and uninstalled/reinstalled Scaler. Still not happening :confused:

What does it suggest if dragging from Scaler to a hex reader shows it’s a file without the chord name?

Thanks for checking.

When I drag chords to the hex reader (HxD) on my Win 10 system it shows the chord name (marker) being part of the .mid file.

This might come from an issue with the temporary file used to copy the chord content into the DAW.

The temporary file is located under:
C:\Users[USERNAME]\AppData\Local\Temp\Plugin Boutique\Scaler2\Scaler-Chord-With-Markers.mid

To access your AppData folder you can type: %appdata% in the path of any Windows Explorer window.

Try to delete the existing files in this folder and try again.
Another issue could be that this file is not copied properly on disk by your system. Check for any app that could restrict file creation or modification like an anti-virus or other security software.

The process from Scaler is pretty simple, the .mid file is stored on disk in this temporary location and then copied to wherever you wish to drag-n-drop it (DAW or a folder on disk). It looks like the file is generated correctly here on a similar system.

I hope this helps,

Tried deleting the contents of the folder, no change. Then the whole folder, no change. But this is funny. I tried the Drag button for two chords with a rest in between. Chord names still don’t come through but…:slight_smile:

Sorry to be pedantic on this but the setting that you change is called EXPORT MIDI MARKERS, and is found on the SESSION tab in the Scaler Settings

This will then export the chord name with the midi file when I drag and drop it into Reaper, but it does not work when I use the midi capture in Scaler (2.8.05b).

Hi @ed66, lest later readers think Ed1 and I are talking about something else, that is exactly the control we are discussing. I showed it in an attachment above.

When ON, export midi markers should include the chord name. Mine has stopped doing that for some reason.

Odder still, my last post shows that when dragging a chord/rest/chord pattern, the name “rest” is part of the file, but still not the chord names.

Hi @mbrowne

This is probably a stupid question, but have you changed any settings relating to markers in Reaper, or have any changed following an update?

Although I play around in Reaper I am not too familiar with all the details of settings.

Thanks for the thought! I have searched and searched for anything that I may have changed but there just isn’t anything. When I set Scaler to Export Midi Markers, the project marker is always there, it just doesn’t create the Chord Name as part of the midi item like it used to.
I don’t see how it can be a Reaper issue, because I’ve run Scaler in two different hosts, Reaper and NanoHost, and when I look at the midi in a hex reader the Chord Name is not part of the file like it used to be.

FWIW, I’ve since tried Scaler in a third host, VSTHost, and opened the midi file in HxD. Even with Export Midi Markers on, chord name is still not part of the file.

Strange. I run Reaper and can drag in the Chords from Scaler and they display fine. Have you checked “View: Toggle show media cues in items” is On via the Actions menu. When this off Chord names will not show.

1 Like

You are absolutely right. This was set to On in my Reaper and it worked. When I set it to Off, the names disappear. It’s been a long time ago so I forgot this setting.

I really appreciate the suggestions! I do have “View: Toggle show media cues in items” ON. I actually have that in my View menu :slight_smile:

Tell me if I’m looking at this wrong, but I do not see this as a Reaper issue, but as a Scaler bug. The reason being that a midi chord created in Scaler, whether Scaler is running as a VST in any of the 3 hosts I’ve tried - Reaper, NanoHost, and VSTHost does not show the name of the chord when I view it in either of the 2 Hex Readers I’ve tried.

And also, it matters not whether the file is dragged from Reaper to desktop, or exported from the midi editor. The chord name is just not in the file.

Very strange!

OK, I am having the same issue with the chord labels not D/D’ ing into Reaper. But I just solved the problem and it is now working fine. My solution just had to do with pushing a lot of buttons. Not in Reaper, in fact I don’t even see the View: Toggle show media cues in items” ion my View menu??

But I did see the “copy chord names to clipboard” with a R-Click of the chords in Scaler. All I did was click it a few times and then low and behold all statred to work fine again when I used the Drag from Scaler to Reaper. I can only say is it worked for me.

Hey, pretty good. And also pretty hilarious. I tried to follow your solution to no avail.

The “toggle show media cues in items” is from the action list, but it’s on by default. I just added it to my menu for troubleshooting this bug.