Newbei question for scaler-2

I’m new to Scaler . I’m on Windows 10 , 64 bit. I’m using protools 22.10.
It seems that everything is working properly, But I can’t get any sound out of scaler 2.5. I’ve tried audio scaler on an audio track. And I have tried scaler 2.5 on an instrument track. Everything seems to work except I can’t get any sound. I’m obviously missing something To get the sound on. I watched several YouTube Videos command read the scaler manual. But I still cannot get any sound from scaler. If anyone can point me in the right direction I would appreciate your helperiod. I hope you can see the picture I put up.

Hi @Rlash Looks like you are loading a scaler audio there which is intended to detect audio. Can you try loading a Scaler (instrument) on to an instrument tracks, also ensure you have the latest version which you can get from your plugin boutique account (Scaler 2.7).

1 Like

Thanks davide,
I did the same on an instrument track wit Scaler (2.7) and got the same results. No sound. Is there something in the i/o I’m missing? I can hear the Mini grand when that track is armed, but i can’t arm both Scaler and the Mini grand tracks at once. When i arm the Scaler track no sound.

Hey Riash

I noticed you did not have any sounds selected in Scaler. Are you trying to use Scaler to drive another instrument or are you trying to use Scaler’s built instruments? I’m not a ProTools user so I can’t tell by your image.


If you continue to have an issue, try creating a project with only a single Scaler track and get a screen capture vs a picture. That might help people tease out your issue.

Good luck

I would say that Riash did not install the instruments because nowhere in my Scaler I have just “< Sounds >”. Normally, there should be “Felt Piano” as default or “OFF” or anything else. I don’t think his DAW could change this. Riash should at least be able to select some unless his sounds are not there. OK, this is another issue.
But, there is also a legitimate question you asked - how he is trying to use Scaler. Waiting for his answer…

Good point. Are you on a Mac or WIn? I’ve seen the “Sounds” UI before but I can’t remember where. I was wondering f it was a Mac thing.

I am on Windows, but I don’t think this should exist on Mac, but not sure.
According to the categorization, Riash is also on Win.

That is not normal on either platform afaik. The fact it says sound and not an instrument leads me to believe the sounds either aren’t installed or Scaler doesn’t know where they are. What is the location of the sound folder if you click on the gear on the upper right and look at locations for the folder?

Hi TmacD,. Thank you for replying. I am trying to get Scaler on its own intruments. I am putting it on its own instrument track now. It appears to be frozen, as it won’t react to anything right now. I am shutting it down and rebooting the system. I am running windows 10 Home. I can not take screen shots of Pro tools for some reason.(works for everything else,thus the phone pics.) As this will take a little while , I’ll let you know. Thank you again.

Thank jamieh.
I beleive you are correct. I could not find the licence file anywhere on my Pc when i downloaded Scaler and the licence. It was suggested I download the licence again. When Scaler opens on my Edit window it says it is “registered” to me. So I am apprehensive of uninstalling and re installing again. I will send a request to see if I can do that. I am running on Windows 10 home edition. I will let you know. Thank you for replying.

Hi @Rlash

Silly question, but having downloaded the licence file, did you register it in Scaler as per following procedure:

How to register license
Click on the register button then point to the folder containing the Scaler2 license file.
Select the license file and enter the email address attached to your Plugin Boutique

If the license is valid, the popup will close and you can start using Scaler

Thanks ed66. Yes i did. I entered my Plugin Boutique log in credentials. When i did , the page with the registration info dropped away , and Scaler was ready to be used. When I open it up now at the bottom of the page it says " registered to -my name.

And I guess you have checked that the sounds folder contains the folders and flac files to create the sounds?

The location of the folder is shown at the bottom of the PREFERENCES tab in the SETTINGS pane.

On my installation it contains 49 folders each of which contains the sound files for an instrument.

If your folder is empty then it suggest that either something went wrong on the installation, or you did not install the sounds when you installed Scaler. A reinstall is probably necessary.

I have had no serious issues on installing upgrade but to be safe, if you are nervous about this, I would suggest uninstalling Scaler and then installing it from scratch using the default settings for the file locations, and ensuring that the option to install the sounds is checked.

1 Like

ed66 , I have now produced sound by putting Scaler on one Track And expand on another. That worked out fine. I will now Try Your suggestion and find the sounds folder. I will let you know how this went. Thank you so much for walking me through this process , As I am not illiterate But also not an engineer. Thank you again.

Apparently there are no sounds in either folder. I don’t recall seeing anything when installing Scaler-2 about sounds , so I will now go through the process of uninstalling and re-installing Scaler-2. Thanks for your patience.

No problem, it is in part why this forum exists, to help users.

Re the install, if I remember correctly there is a check box during the install process which must be checked to install the sounds.

Apparently there are no sounds in either folder. I don’t recall seeing anything when installing Scaler-2 about sounds , so I will now go through the process of uninstalling and re-installing Scaler-2. Thanks for your patience.

You should carefully watch the checkboxes during the installation. Check them all, except the plugin formats you don’t need (VST2, VST3, AAX).

After much coaching and patience from this team , I’ve been able to re install Scaler-2, And now have a working version of this great app. Everything is working properly, And can now start figuring out its workflow And how to use it correctly. Although I still haven’t figured out exactly beware the instruments are located, they are installed and working. Thank you all very much , And now the fun begins. Thank you again.