Newbie question on recording in Ableton

I am simply trying to record a chord progression triggered by midi keys but I keep getting playback of the performance settings in Scalar2 when I playback and during the recording.

My procedure is:

  1. Create my chord progression in Section C pattern1
  2. In DAW sync mode, hit record in the midi track
  3. Press on my keys to sound the chords and the keys I press are recorded into Ableton track

However, during my recording and when I playback, I still get the default performance in Scalar2 using the durations and timings in the playback settings. I have looked in the Scalar2 configuration and I don’t seem to be able to find settings to stop the Scalar2 performance and only play the chords triggered by my midi notes. I have seen playback of the recorded notes done in many of the videos for Scalar2 but I must be missing something really simple.



What is happening is correct. What Ableton is seeing is just your input notes. Scaler MIDI is not routed anywhere to record. You can handle this one of 2 ways - In Scaler you can turn on MIDI Capture to the right of section C —

Then play your DAW and play the chords in the order you want when finished stop the DAW, stop the MIDI capture and drag and drop the captured MIDI to a MIDI track —
Screen Shot 2021-06-11 at 9.10.47 PM
OR without even doing that you can lasso all the chord pads and drag and drop the MIDI chords direct to a MIDI track —

OR you can route scaler to a MIDI track and record that track as you play —

If you have performance turned on the MIDI clip will look something like this —

If you have Performance turned OFF you’ll just see the chords like this –

The duration of the chords depend on the sending in preferences here —
Screen Shot 2021-06-11 at 9.19.55 PM

1 Like

Thanks for the quick reply Jamieh, but maybe I didnt quite explain the issue that I am having.

In the tutorial videos, Davide Carbone just records the trigger notes by using the record function in the DAW and on play back you just hear the chords from scalar2 triggered by the recorded midi notes and he can then continue to adjust them and try different voicing etc.- not using midi capture and actually placing the individual midi notes of the chords into the midi track. I don’t hear any of the chords being played using the default Scalar performance settings.

Just trying to work out how that was done so that I can adjust the chord settings in scalar2 but use my just my recorded midi trigger notes to sound the chords.

You record your trigger notes but they don’t play Scaler to trigger the chords when you play the clip? I’m not clear on the issue.

Scalar2 plays my triggered chords AND the chords using the performance section durations and timings. I am simply trying to get my chords and timings to play without the chords being played using the default performance settings.

If Performance is on you can turn it off by clicking on the BLUE PERFORM word on the upper right.
Screen Shot 2021-06-11 at 10.14.12 PM