No internal MIDI patches showing as available [SOLVED]

Just installed v2.0 - it’s absolutely wonderful!

I’m using it inside Logic Pro, and I can load up an instrument from within Logic, and have it play in Scaler, however, when I click on the Midi FX button to access the patches (eg Felt Piano) button, there are no internal patches showing. Is there something I need to do to load the internal sounds and make them available in Scaler?

Many thanks, and congrats on the new release, I love it!

Just to clarify: when I click on MIDI FX in Scaler, expecting to see the list of internal instruments from Scaler, I get the response ‘No sound output’. When I go to settings, the path is set to /Users/Shared/PluginBoutigue/Scaler2/Sounds, and I see all of the instruments folders are there.

In case anyone is having the same problem: I loaded Scaler 2 as a MIDI FX in Logic, which causes this problem. If instead I load it as an instrument, then it works fine, and all sounds are accessible. This is clearly demonstrated in the instruction video:

My bad! Ok, all good. I’m not sure then why I would ever load it as a MIDI FX in Logic, ie what that option exists, and how it differs from loading as an instrument, but will load as an instrument from now.

1 Like