No looping of pattern in daw-sync-mode?

why the loop function is disabled, when synced scaler to the daw? in my eyes it is a must to be able to loop the pattern especially when synced to the daw … like it is it only playes once - and then?

please! :slight_smile:

1 Like

This surprised me as well.

1 Like

Loop in the DAW and scaler responds. That’s how any DAW sync works across any midi hardware I have. If DAW sync is disabled then loop in scaler. Scaler is master or slave.

that i know! BUT!!! when the looping area in the daw is 32 bars long and the chord progression in scalar is only two bars long, scalar stops playing after two bars :wink: that you should change, that scalar LOOPS its progression - otherwise scalar is synced, but does NO looping! :wink:

I think this is the way I was perceiving it. I wanted Scaler to loop when it gets to the end of the progression.
But, that being said I think now that it’s probably fine the way it is. You can set up a pattern or patterns corresponding to the section you are working on and loop that by syncing to the DAW for however many bars that is with maybe a rest at the start and finish to give you a count in and out buffer. The more I think of this it is good the way it is. You would have to do it in the DAW or Scaler either way. This thing is always surprising me with it’s brilliance! More genius!

It’s a very good point must be said. Should it loop its own section when the DAW loop is longer. Then yes why not? Let me speak to the others to discuss but unless there’s something from a DEV point that I am not seeing yes this should occur. Thanks!

1 Like

I do a lot of idea generating in Ableton Live is Session view so I can set up scenes to try out different ideas before heading to arrangement view. Having Scaler loop at end of progression would be ideal in this scenario. In Arrange view or how most people work then the current way works as I stated above but having the option to do either would be best.

in abletons live it also happens, that, when you have a long progression - say 8 chords - each plays four times - and the drum loop you have in ableton is only 2 bars long - scalar does not play its own progression to the end. it restarts after two bars of the first chord …

in my eyes scalar MUST be able to loop its progression - in its full length - and synced to the daws tempo. especially when you work in clip-view with live.

Whilst I agree with you on scaler looping a shorter progression than the length of your DAW loop I don’t agree on the playing full progression when DAW loop is shorter. That is counter intuitive and not how any host sync software or hardware works, I know that you want it to behave like clip view does but scaler isn’t intended to work clip view mode.

1 Like

in live and bitwig you normaly do not have tracks with bars at the beginn of a project. you have different short elements of clips. all in different lengths. so everything loops at oits own lengt. and i think its really important, that scaler is also able to loop its progressen without the need of an defined loop-lenght from the daw. - scalers loop lenght always should be its own lenght of the progression!

the most need of scaler is in live and bitwig - because theres nothing like chord-tracks. so please add the possibility to loop the length oif the progression at its own dimension.

so, that you do not always have to export the progression into an clip, when you wanna loop it at its own lenght. - because every change in chord you wanna do after in scaler - you have to reexport the whole thing. - and often we use arpeggiators in live and bitwig for testing and findin ideas. but its difficult, when scaler does restart the loop after its second chord in long progressions … and i often have that issue :wink:

Hmmmm, very trick and I see your point. Thanks for sharing. Let us discuss on this end.