No Midi passing through Scaler 2 MidiFX plugin in Logic 10.7 on Monterey

With ScalerControl 2 active as a midiFX on a channel strip, seemingly no midi is passing through to the instrument plugin. If I play the keyboard, I see the keys lighting up inside scaler etc, but I got no sound from the instrument that it’s feeding into. Disabling Scaler control and I control the instrument just fine.

Perhaps something to do with the new midi routing options? I dunno, makes scaler a bit non-functional for the time being though. Running scaler as an instrument plugin works fine, but that is not my workflow.

1 Like

Hey @Blorp

thanks for reporting your issue. Are you running Scaler on an M1 machine? If yes, you can try running Logic under Rosetta and check if it works using ScalerControl


Hi Ed

I’m still on Intel. Everything worked fine before Monterey. I tried reinstalling scaler but it made no difference.

Also, I just checked with Scaler 1, and I get the same behaviour with that too.

Edit: after seeing Pinzer’s post, I checked other 3rd party midiFX plugins, and can confirm it seems to be all 3rd party midiFX that are causing midi to not get through. So it’s not a scaler issue.

1 Like

I just tested mine- intel running the latest Logic Pro and Monterey and it is working, Are you using Logic pro 10.7

1 Like

Hmm interesting. Yes it happens on 10.7. I have 10.6.3 too and it works fine there.

Same here. on my mini (Intel) with latest Logic 10.7 and Monterey since a few days all is fine.
@Blorp what about other Midifx? Are those running well? Can you provide us with a short video?

The stock Logic MidiFX all work fine, it’s just the third party ones that aren’t working (I’ve only got four, but they all do it)

Here’s a bad video with no sound, but you can see the level meter stop every time I enable one of the third party FX. As far as I’ve seen it makes no difference which MidiFX I have open, or what the settings are.

It’s quite confusing that it’s not happening to everyone! I’ve tried clean reinstalling both the plugins and Logic, and well as re-updating Logic from 10.6.3 (which still works fine), but I still get the same behaviour. I’m at a loss to what other troubleshooting steps to take to get to the bottom of what’s causing it.

Sticking with 10.6.3 is a perfectly fine workaround for the time being, but hopefully 10.7.1 isn’t too far away.

1 Like

We have seen those issues on some of our machines as well, on Intel and M1 running Monterey. Earlier versions of macOS and Logic seem fine.

Another good reason to never update too soon, hopefully a patch is coming.

Still broken on 10.7.1, hrmph. Come on Apple! You can do it!

Late but now I got the same issue with the 10.7.1. update sic!

I’m using Scaler 2.5 in Logic 10.7.1 Monterey 12.0.1…

the Midi FX version of Scaler is not producing any sound on my instrument! please fix this.

Please report the issue to Apple. This is an issue with all 3rd party midFX on Logic 10.7 and 10.7.1. It’s not a Scaler issue.

New Scaler user here. Like others here, I was disappointed to find that it wasn’t working in Logic MIDI FX. In fact, no other third party MIDI FX seems to be passing data to instruments. But curiously, Apple MIDI FX are working. I searched around and haven’t seen any solid solutions yet. But I did discover that switching OFF the Logic Pref for MIDI 2.0 got things going again. Not sure it’s performing as it should, but maybe there’s a hint there for the debugging team.


Good observation re Midi 2.0. For me that solves the problem of it not passing any midi through, but only for a single instance of Scaler. If I have Scaler midiFX on multiple tracks, only the most recently added one works.

Apple still got work to do :frowning:

You legend!
Turning off MIDI 2.0 worked!
This post should be pinned by the mods!
nice one!

1 Like

I just got a response from Plugin Boutique who say that Scaler requires that I purchase a $99 vst host (black cat patchwork) for it to work in Logic 10.7. That’s a pretty unsatisfying response and had I known about this flaw, I might not have purchased Scaler at all. I hope they come up with a real fix or start dishing out refunds. Sorry, I’m a bit annoyed.

It’s Apple you should be annoyed at. They are the ones that broke the Logic 3rd party MIDI FX functionality. They are the ones that need to fix it.

Yes. Just expressing general annoyance :slight_smile: I did file a bug report with Apple. Hope a fix comes sooner than later.

Did they say why ? I bought Blue Cat (suggested by Plugin Boutique) to try out Instacomposer (unimpressed) and found it was totally impractical to work with live - it’s conceptually flawed for that role as far as I can see.

However, there are several work rounds for that particular issue which are free.

What was the issue with Logic ? Was it the midi pass through ? I don’t see how Blue Cat could solve that.

No. They just pointed to some fine print in Scaler’s system requirements that say “Logic Pro 10.7 and above: No MIDI Routing, Use Blue Cat Patchwork”. Not really what I signed up.