No possibility of registration / Démo mode

I bought scaler 1.8.1 yesterday and it’s a demo version with no possibility to register. In addition the demo has problems (and remains stuck on “purchase a license”. Unable to register.

What is the issue ?

Hi @samba and welcome,

have you tried what is said here :

If your issue is persistent after those operations, please provide us more information about your operating system and DAW.


Hi and thanks for the reply.
So, I updated my computer, reboot after installation.
here the information about my operating system and DAW


By leaving Scaler in its original folder I was able to register, the soundfont being restored (I created a shortcut to scaler in the vst folder of Ableton Live) but it did not last.
I worked on scaler for 2 hours and the soundfont disappeared without having changed anything …dossier vst

i tried to cancel the sortcut i put in the main vst file of Ableton and i try to rescan from the default location… but no… scaler stay the same… without soundfont…

I’m kind of mad about this, your software is really cool
What can I do please ?

Could be an Ableton issue. Can you try Reaper? Or there is a sweet little standalone app called Nanohost which will allow you to load Scaler in standalone mode. This may help you troubleshoot.

I had the same issue. I solved but can’t tell how.
Try changing your keyboard and language to English before install.
Try windows update.
Font reset and font cache cleaning.
It’s not ableton issue for sure.

Good luck. It took me two days.

Yep. I took time…
Thanks for all the help
yeah i think it was the font cash stuff…but I did a lot of stuff in the same time…
So thanks again
Safe and Sound

I have the same issue with my mac and Ableton

Please help or forward this message to appropriate person for urgent answer.

Why current trial version of Scaler download is not showing user license after trial download? Where can I get it if it is not available according to instructions?

It is not possible to make any purchases if I cannot try this product properly and if there is no adequate support available.

I have sent already one email previously, messages in FB and messenger and tried to call - all without any success.

Is this company in business?