No sound after updating to 2.7.0

I just updated Scalar 2 for the first time from the first state to 2.7. And now i don’t have any internal audio output. When i click a chord on the interface, i will click the mouse and the button wont press down to preview the chord. I also tried playing a key on the interface of Scalar 2 wherec the keys are and there is no sound. Please help

I am using a laptop and FL 20 on Windows

Hi @Blaku792 Welcome to the forum, I’ll let any other users chime in but firstly have you restarted you PC and opened a naked session and then tried loading Scaler?

1 Like

Yes sir. I tried loading with Kontakt and using kontakt as the sound bank, still got nothing. I tried dragging chords into another vst and it wont even drag notes from the interface itself.

I also noticed I can’t download Scaler 2.6.0. I can only go back to the previous version 2.1.0 and 2.2.0.

I had to go back to 2.2.0 because thats the only version that would work.

I also tried Uninstalling it completely and then installing it from 2.7.0 and srill didnt work.

Same here no sound on Intel Mac logic pro. Going back to 2.6 solved the issue.
The installer acts funny. taking a long time message “waiting for other installers to finish”, but there are no other installers active. After a while it finishes successfully, but no sound. Rebooting didin’t help either.
Tried multiple times.

Strange. I am on Intel Mac Logic and Monterey and everything works as expected. Did not see the message “waiting for other installers to finish”. Sorry, cannot help…

I’m sure all Logic Pro User will have checked this, but just in case.

When I first installed Scaler, the same thing happened with sound problems. I did all the usual things reboot and checked the Sound option in Apple>System Preferences.

Then opened LPX and went to Logic Pro>Settings (what used to be Preferences)>Audio.

The Output and Input Devices had reverted back to an old device MMAudio, that I don’t have now. Change this back to my present Interface and bingo!

Mac OS 12.6 Monterey MacBook Pro M1
Logic Pro 10.7.4

Now things are starting to make sense

Not the solution for me. I still had sound on other VST’s. Only in scaler there was no sound.
But I also found the solution.
I never looked at the preferences in scaler before because it worked out of the box.
There is a midi channel setting there and a multi voice output. Which showed channel 1 and off after changing back and forward. The notes showed on the keyboard in scaler and the sound came back.
So that’s maybe a tip for other users?


Hi Henk,

Well, that’s related to the new feature, so definitely something to keep an eye on.

Thanks for the heads up!

1 Like

I can try it. However, for me, whenever i click a chord, the little hand which is the mouse doesn’t tap the button for the chord to play. I still can’t drag Chords outside of the interface to any other instrument. I can’t even download earlier versions of Scaler such as 2.6… i can only download the first 3 versions… I’m pissed

No sound from Scaler on studio one 5 either.
I see input signal on midi track but no output on channel. Midi track is armed and set out to scaler.
In Scaler I see the load bar update above the sound set selection and when I click a chord there is no sound either!
From what I see the OP wasn’t solved either.

Contact pluginboutique support. You should see all versions there from the one you bought onward.

Screen Shot 2022-11-05 at 8.51.38 AM

Just tried your suggestion, I just picked another channel (settings/prefs)and then all channels working now. Looks like I have to do this with each project though so must be a bug.

1 Like

Started up today and scaler now plays sound back without intervention. Must of needed total shutdown of computer and reboot.

The good old shutdown and reboot… :disguised_face: Sometimes I could do with that! Good to hear you’re up and running.


Alright everyone, so all I did was check the preferences and turned the Multi-Voice Output On and set as default.

Apparently it was turned off and once I turned it on it let me play sounds and everything. I absolutely LOVE this tool and I am glad to be able to experience the 2.7 update.

Thank you all here at the Scaler Plugin forum family for sharing your piece and chipping in. I also will be trying to help others with any difficulties if I can be of any help.

Just set it as default my man and youll be good!