No sound from Midi Effect in Logic Pro X

Hi there,

I admit to being a beginner, but I’m really confused. I’m trying to use Scaler, which I just bought, together with Logic Pro X. I’m using it as a Midi Effect, but I hear no sound. All other Midi Effects work though.

Here’s what I did:

  • selected the Yamaha Grand Piano as my Software Instrument
  • selected ScalerControl 2 Midi Effect under Audio Units -> Plugin Boutique -> ScalerControl 2
  • hit the Scales Button, then selected a scale
  • hit the section B midi bind button
  • playing keys on my keyboard results in the virtual keyboard in the Scaler plugin to show me which keys I’m playing
  • no sound

I tried many variants on this.

Please help me, I really don’t know what I’m doing wrong.

Thank you in advance,

Candide

Hi @candide

You can have a look at this video if it helps but it seems you are doing everything correctly…

Scaler will output all of its MIDI message onto the channel 1, is your instrument listening to a specific MIDI channel?

Hi Ed1,

Thank you for your quick response. I’m doing everything exactly as described in the video you joined to your message.

Since I had an old Scaler Demo plugin installed, I went to remove it completely from my Mac (in the Finder -> /Library/Audio/Plug-Ins/Components), to no avail.

More information: I’m using macOS Mojave (Version 10.14.6), and Logic Pro X v 10.5.1

I’m happy to post a video of what I’m doing if you want, or we can also do a debugging session using Skype, Zoom, TeamViewer, etc.

I also tried using Scaler in Ableton Live 9: same results.

Cheers,

Candide

More:

I tried uninstalling and reinstalling the very latest version: no luck either.

I also asked a seasoned music professonial to look at my setup and I only got him perplexed.

It simply looks like no midi output is produced by the plugin. The only thing I can do is dragging chords to into my workspace, but that comes short of what I’m interested in doing with this plugin.

Again, all other plugins work fine.

@candide
Can you try the following steps for me please?
Reboot you MAC
Reinstall Scaler 2
Reboot your MAC
Open Logic with a new project (not an existing project).
Go to preferences plugin manager
select Scaler 2 and ‘Reset and Rescan’ selection
Now try loading Scaler 2 as an instrument first and ensure it is playing its own internal sounds
Now try the MIDI FX Scaler and passing it to a Logic internal instrument

Hey davide,

I just got it to work by making a brand new configuration in Audio Midi Setup on my Mac.

Thank you anyway,

BR,

Candide

Can you provide any further detail on how you figured out this solution?

I"m seeing multiple people who are having this problem and support doesn’t seem to be helping anyone.