No sound from Scaler

I can’t find any solutions in forums or FAQs yet. Before and after the update both have no sound. Many plugins work alongside. It’s weird because Scaler 1 and 2 both worked fine then a couple of days ago, Scaler just quit making sound. I looked in FAQs and nothing. Most answers are like, “Load it on a track with an instrument” or “make sure midi for the track is enabled.” These answers are NOT the problem. There is something else going on, tis why I am here. Is there a solution yet?

1 Like

I have the same problem. It was working fine went to bed . When I opened my session no sound from Scaler. thought the update would fix it but, NO it didn’t. Making beats without Scaler is LONG…
Can we fix this ASAP.

Sorry you are experiencing this, would you mind giving us more info about your config so we can investigate further: Operating System, DAW, Audio Interface,…

Have you tried to change your audio settings? Maybe trying in a different DAW or with another audio interface if you can and see if it helps.


I use FL 20.71 on Windows 10 FL Asio I have been using Scaler without any problems, can be Glitchy at times. but this is unusable. Tried routing to another vst no joy.

Tried a different asio no joy
All my other VST’S work but not scaler2

OS is Windows 10
DAWs are FL Studio, MPC Beats and Tracktion Waveform 11.
Not using an external audio interface yet. I am using 2 keyboards, M Audio Keystation 61s and Akai Mpk Mini 2.
Seems that Scaler and Scaler 2 are the elephant in the room; No sound in either DAW with either keyboard

Scaler rocks and I hope there is a solution soon. Until then, EzKeys is the better bet. Had it for years and no problem in any daw with any keyboard. Worked well with Scaler until it quit working the other day. What’s up with that?

The GOOD NEWS IS that SCALER is amazing! After almost giving up, I tried what EVERYONE was talking about… “Rebooting the computer”. Scaler and SCaler 2 works perfectly.
I think it is that Scaler is up to date where Windows was not and once the system updates, then newer plugins like Scaler work.
Thank you.

1 Like